summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-03 12:00:16 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-03 12:00:16 +0000
commit3af5578a331b278be723a915c4fc482d9dd91866 (patch)
tree89b8bc14befe4e63b35e4dfcbdde20305c18ae40 /x11-libs/libdrm/libdrm-2.4.20-r1.ebuild
parentAdd stable keyword for s390, which was missed by `ekeyword all'. (diff)
downloadgentoo-2-3af5578a331b278be723a915c4fc482d9dd91866.tar.gz
gentoo-2-3af5578a331b278be723a915c4fc482d9dd91866.tar.bz2
gentoo-2-3af5578a331b278be723a915c4fc482d9dd91866.zip
Re-add 2.4.20-r1 for fbsd
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libdrm/libdrm-2.4.20-r1.ebuild')
-rw-r--r--x11-libs/libdrm/libdrm-2.4.20-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-libs/libdrm/libdrm-2.4.20-r1.ebuild b/x11-libs/libdrm/libdrm-2.4.20-r1.ebuild
new file mode 100644
index 000000000000..41a39bd74de0
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.20-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdrm/libdrm-2.4.20-r1.ebuild,v 1.13 2012/06/03 12:00:16 chithanh Exp $
+
+EAPI=3
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="http://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://dri.freedesktop.org/${PN}/${P}.tar.bz2"
+fi
+
+KEYWORDS="~x86-fbsd"
+IUSE="kernel_linux"
+RESTRICT="test" # see bug #236845
+
+RDEPEND="dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # Fixes buidling of x11-drivers/xf86-video-openchrome, Gentoo bug 298352,
+ # upstream bug 26994
+ "${FILESDIR}"/2.4.18-0001-datatypes.patch
+ )
+
+pkg_setup() {
+ # libdrm_intel fails to build on some arches if dev-libs/libatomic_ops is
+ # installed, bugs 297630, bug 316421 and bug 316541, and is presently only
+ # useful on amd64 and x86.
+ CONFIGURE_OPTIONS="--enable-udev
+ --enable-nouveau-experimental-api
+ --enable-vmwgfx-experimental-api
+ $(use_enable kernel_linux libkms)
+ $(! use amd64 && ! use x86 && ! use x86-fbsd && echo "--disable-intel")"
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "libdrm's ABI may have changed without change in library name"
+ ewarn "Please rebuild media-libs/mesa, x11-base/xorg-server and"
+ ewarn "your video drivers in x11-drivers/*."
+}