summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-09-25 12:43:34 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-09-25 12:43:34 +0000
commit483edcd6f1d4b39ceb4fc2a27a0043d427529c4b (patch)
tree61b7906eeab4991f902579ba1b0cd3655fb3e22f /x11-libs/libyui-ncurses
parentRemoved vulnerable versions (diff)
downloadgentoo-2-483edcd6f1d4b39ceb4fc2a27a0043d427529c4b.tar.gz
gentoo-2-483edcd6f1d4b39ceb4fc2a27a0043d427529c4b.tar.bz2
gentoo-2-483edcd6f1d4b39ceb4fc2a27a0043d427529c4b.zip
Fix building with sys-libs/ncurses[tinfo]
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'x11-libs/libyui-ncurses')
-rw-r--r--x11-libs/libyui-ncurses/ChangeLog6
-rw-r--r--x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch21
-rw-r--r--x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild8
3 files changed, 31 insertions, 4 deletions
diff --git a/x11-libs/libyui-ncurses/ChangeLog b/x11-libs/libyui-ncurses/ChangeLog
index 153a04c5e63f..8ce5072e0d7f 100644
--- a/x11-libs/libyui-ncurses/ChangeLog
+++ b/x11-libs/libyui-ncurses/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libyui-ncurses
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-ncurses/ChangeLog,v 1.3 2014/09/23 17:13:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-ncurses/ChangeLog,v 1.4 2014/09/25 12:43:34 pinkbyte Exp $
+
+ 25 Sep 2014; Sergey Popov <pinkbyte@gentoo.org> libyui-ncurses-2.46.4.ebuild,
+ +files/libyui-ncurses-2.46.4-tinfo.patch:
+ Fix building with sys-libs/ncurses[tinfo]
*libyui-ncurses-2.46.4 (23 Sep 2014)
diff --git a/x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch b/x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch
new file mode 100644
index 000000000000..b69aafe797b1
--- /dev/null
+++ b/x11-libs/libyui-ncurses/files/libyui-ncurses-2.46.4-tinfo.patch
@@ -0,0 +1,21 @@
+Fixes building with sys-libs/ncurses[tinfo]
+
+--- cmake/Modules/FindCurses6.cmake.orig 2014-09-25 16:32:20.000000000 +0400
++++ cmake/Modules/FindCurses6.cmake 2014-09-25 16:33:16.000000000 +0400
+@@ -11,11 +11,12 @@
+ FIND_LIBRARY(CURSES6_TINFO_LIBRARY NAMES tinfo PATHS ${path}/ncurses6 ${path} NO_DEFAULT_PATH)
+ ENDFOREACH()
+
+-SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY})
+ # tinfo is optional (in 12.1 is not there)
+-IF(${CURSES6_TINFO_LIBRARY})
+- SET(CURSES6_LIBRARIES "${CURSES6_LIBRARIES} ${CURSES6_TINFO_LIBRARY}")
+-ENDIF(${CURSES6_TINFO_LIBRARY})
++IF(NOT ${CURSES6_TINFO_LIBRARY} STREQUAL "CURSES6_TINFO_LIBRARY-NOTFOUND")
++ SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY} ${CURSES6_TINFO_LIBRARY})
++ELSE()
++ SET(CURSES6_LIBRARIES ${CURSES6_NCURSESW_LIBRARY} ${CURSES6_PANELW_LIBRARY})
++ENDIF()
+
+ FIND_PATH(CURSES6_INCLUDE_DIR ncurses.h PATH_SUFFIXES ncurses6)
+
diff --git a/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild b/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild
index 2b96ffa55019..c4aba4c3ce43 100644
--- a/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild
+++ b/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild,v 1.1 2014/09/23 17:13:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui-ncurses/libyui-ncurses-2.46.4.ebuild,v 1.2 2014/09/25 12:43:34 pinkbyte Exp $
EAPI=5
@@ -23,13 +23,15 @@ RDEPEND="sys-libs/ncurses
DEPEND="${RDEPEND}
dev-libs/boost"
+PATCHES=( "${FILESDIR}/${P}-tinfo.patch" )
+
S="${WORKDIR}/${PN}-${PN}-master-${PV}"
src_prepare() {
cp "${EPREFIX}/usr/share/libyui/buildtools/CMakeLists.common" CMakeLists.txt || die
- # TODO: set proper docs deps and USE flag for building them
- sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
+ # TODO: set proper docs deps and USE flag for building them
+ sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
cmake-utils_src_prepare