summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-29 20:03:53 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-29 20:03:53 +0000
commit7b50de575d8abb8116b452178452006e8f46d5ab (patch)
tree501565d4148f5d41a7e6924389fdcb53549c5019 /x11-libs/openmotif
parentmarking -r3 stable, adding -r4 with a couple of patches from cvs. (Manifest r... (diff)
downloadgentoo-2-7b50de575d8abb8116b452178452006e8f46d5ab.tar.gz
gentoo-2-7b50de575d8abb8116b452178452006e8f46d5ab.tar.bz2
gentoo-2-7b50de575d8abb8116b452178452006e8f46d5ab.zip
added an #undef X_LOCALE before including XLocale.h, otherwise locale.h isnt included and compilation fails with gcc 3.4
Diffstat (limited to 'x11-libs/openmotif')
-rw-r--r--x11-libs/openmotif/ChangeLog7
-rw-r--r--x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch12
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r5.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 981d7f71a9ae..a9b1bfb7a8f7 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.43 2004/05/12 15:42:57 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.44 2004/05/29 20:03:53 lv Exp $
+
+ 29 May 2004; Travis Tilley <lv@gentoo.org>
+ +files/openmotif-2.1.30-gcc34.patch, openmotif-2.1.30-r5.ebuild:
+ added an #undef X_LOCALE before including XLocale.h, otherwise locale.h isnt
+ included and compilation fails with gcc 3.4
12 May 2004; Ciaran McCreesh <ciaranm@gentoo.org>
openmotif-2.1.30-r4.ebuild:
diff --git a/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch b/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch
new file mode 100644
index 000000000000..d7d56295e103
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch
@@ -0,0 +1,12 @@
+--- motif.old/lib/Xm/Scale.c 2004-05-29 15:39:27.089621032 +0000
++++ motif/lib/Xm/Scale.c 2004-05-29 15:44:09.597673280 +0000
+@@ -81,6 +81,9 @@
+ #ifdef __cplusplus
+ extern "C" { /* some 'locale.h' do not have prototypes (sun) */
+ #endif
++#ifdef X_LOCALE
++#undef X_LOCALE
++#endif
+ #include <X11/Xlocale.h>
+ #ifdef __cplusplus
+ } /* Close scope of 'extern "C"' declaration */
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
index e69c83146451..2930b2692a1a 100644
--- a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
+++ b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.3 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.4 2004/05/29 20:03:53 lv Exp $
inherit eutils
@@ -59,6 +59,7 @@ src_unpack() {
# compile on gcc 2.9x
epatch ${FILESDIR}/${P}-imake-ansi.patch
epatch ${FILESDIR}/${P}-uil-bad_grammar_fix.diff
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {