summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-07-01 19:30:39 +0000
committerUlrich Müller <ulm@gentoo.org>2008-07-01 19:30:39 +0000
commitcdac5246f8e0620e7c5267734a74fabe24426fb4 (patch)
treef2d324aee022f55822065841694fd81c08d41034 /x11-libs/openmotif
parentstable amd64, bug 230369 (diff)
downloadgentoo-2-cdac5246f8e0620e7c5267734a74fabe24426fb4.tar.gz
gentoo-2-cdac5246f8e0620e7c5267734a74fabe24426fb4.tar.bz2
gentoo-2-cdac5246f8e0620e7c5267734a74fabe24426fb4.zip
Support utf8 and depend on libiconv if (and only if) USE=unicode.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686)
Diffstat (limited to 'x11-libs/openmotif')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/openmotif-2.3.0-freebsd-libiconv.patch12
-rw-r--r--x11-libs/openmotif/openmotif-2.3.1.ebuild7
3 files changed, 21 insertions, 4 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index c1cc37743aae..a5180e087147 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.190 2008/06/29 12:39:13 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.191 2008/07/01 19:30:39 ulm Exp $
+
+ 01 Jul 2008; Ulrich Mueller <ulm@gentoo.org>
+ files/openmotif-2.3.0-freebsd-libiconv.patch, openmotif-2.3.1.ebuild:
+ Support utf8 and depend on libiconv if (and only if) USE=unicode.
29 Jun 2008; Ulrich Mueller <ulm@gentoo.org> openmotif-2.3.0-r1.ebuild,
openmotif-2.3.0-r3.ebuild:
diff --git a/x11-libs/openmotif/files/openmotif-2.3.0-freebsd-libiconv.patch b/x11-libs/openmotif/files/openmotif-2.3.0-freebsd-libiconv.patch
index e81bc9c2bd62..1ed3ddc54d51 100644
--- a/x11-libs/openmotif/files/openmotif-2.3.0-freebsd-libiconv.patch
+++ b/x11-libs/openmotif/files/openmotif-2.3.0-freebsd-libiconv.patch
@@ -10,3 +10,15 @@
fi
AC_FIND_XFT
+--- openmotif-2.3.0-orig/lib/Xm/ResEncod.c 2006-11-21 20:50:31.000000000 +0100
++++ openmotif-2.3.0/lib/Xm/ResEncod.c 2008-07-01 20:29:19.000000000 +0200
+@@ -50,7 +50,9 @@
+ #endif
+ #include <string.h>
+ #include <ctype.h>
++#ifdef UTF8_SUPPORTED
+ #include <iconv.h>
++#endif
+ #include <errno.h>
+ #include <Xm/XmosP.h>
+ #include "MessagesI.h"
diff --git a/x11-libs/openmotif/openmotif-2.3.1.ebuild b/x11-libs/openmotif/openmotif-2.3.1.ebuild
index 3a47f24ce239..2099dcd495cb 100644
--- a/x11-libs/openmotif/openmotif-2.3.1.ebuild
+++ b/x11-libs/openmotif/openmotif-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.1.ebuild,v 1.2 2008/06/28 08:46:27 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.3.1.ebuild,v 1.3 2008/07/01 19:30:39 ulm Exp $
inherit eutils flag-o-matic multilib autotools
@@ -13,7 +13,7 @@ SRC_URI="ftp://ftp.ics.com/openmotif/${PV%.*}/${PV}/${P}.tar.gz
LICENSE="MOTIF libXpm doc? ( OPL )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc examples jpeg png xft"
+IUSE="doc examples jpeg png unicode xft"
# make people unmerge motif-config and all previous slots
# since the slotting is finally gone now
@@ -22,7 +22,7 @@ RDEPEND="!x11-libs/motif-config
!<=x11-libs/openmotif-2.3.0
x11-libs/libXmu
x11-libs/libXp
- virtual/libiconv
+ unicode? ( virtual/libiconv )
xft? ( x11-libs/libXft )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )"
@@ -93,6 +93,7 @@ src_compile() {
append-flags -fno-strict-aliasing
econf --with-x \
+ $(use_enable unicode utf8) \
$(use_enable xft) \
$(use_enable jpeg) \
$(use_enable png)