summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-27 15:21:32 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-27 15:21:32 +0000
commit4f616015a78951b84211fb304e4d8350c2074088 (patch)
tree9ba27ad0ed3723d59db7d8357094bfdb10768ae6 /x11-libs/pango
parentgnome 2.1 (diff)
downloadgentoo-2-4f616015a78951b84211fb304e4d8350c2074088.tar.gz
gentoo-2-4f616015a78951b84211fb304e4d8350c2074088.tar.bz2
gentoo-2-4f616015a78951b84211fb304e4d8350c2074088.zip
gnome 2.1
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.1.21
-rw-r--r--x11-libs/pango/pango-1.1.2.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 3ffbe12925b0..d2a7d292b351 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.13 2002/10/13 23:02:15 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.14 2002/10/27 15:19:16 foser Exp $
+
+*pango-1.1.2 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> pango-1.1.2.ebuild :
+ gnome 2.1
*pango-1.0.5 (14 Oct 2002)
diff --git a/x11-libs/pango/files/digest-pango-1.1.2 b/x11-libs/pango/files/digest-pango-1.1.2
new file mode 100644
index 000000000000..e744f39634ac
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.1.2
@@ -0,0 +1 @@
+MD5 cd76cc74ed2e3c74c6af19b5d5fd10ad pango-1.1.2.tar.bz2 758864
diff --git a/x11-libs/pango/pango-1.1.2.ebuild b/x11-libs/pango/pango-1.1.2.ebuild
new file mode 100644
index 000000000000..51ca68427591
--- /dev/null
+++ b/x11-libs/pango/pango-1.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.1.2.ebuild,v 1.1 2002/10/27 15:19:16 foser Exp $
+
+IUSE="doc"
+
+inherit libtool debug
+
+SLOT="1"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+
+ econf ${myconf} --without-qt || die
+ make || die "serial make failed"
+}
+
+src_install() {
+ einstall
+ rm ${D}/etc/pango/pango.modules
+
+
+ dodoc AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}
+