summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-13 00:07:40 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-13 00:07:40 +0000
commit629c94604f6ff90bc605b01a71227abe66b4297c (patch)
tree22eb07ba7235d04c33c6764c0d45de5e7044cc86 /x11-libs/pango
parentMasking oldstyle again (diff)
downloadgentoo-2-629c94604f6ff90bc605b01a71227abe66b4297c.tar.gz
gentoo-2-629c94604f6ff90bc605b01a71227abe66b4297c.tar.bz2
gentoo-2-629c94604f6ff90bc605b01a71227abe66b4297c.zip
GNOME 2.1.2 commit
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.1.31
-rw-r--r--x11-libs/pango/pango-1.1.3.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 03be55c1d555..e276c695336c 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.15 2002/11/02 22:26:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.16 2002/11/13 00:07:40 foser Exp $
+
+*pango-1.1.3 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> pango-1.1.3.ebuild :
+ GNOME 2.1.2 release
*pango-1.1.2 (27 Oct 2002)
diff --git a/x11-libs/pango/files/digest-pango-1.1.3 b/x11-libs/pango/files/digest-pango-1.1.3
new file mode 100644
index 000000000000..d83c5c887b83
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.1.3
@@ -0,0 +1 @@
+MD5 34f4c5486b9428d8c738acc0c76ed669 pango-1.1.3.tar.bz2 766579
diff --git a/x11-libs/pango/pango-1.1.3.ebuild b/x11-libs/pango/pango-1.1.3.ebuild
new file mode 100644
index 000000000000..1060f330cae3
--- /dev/null
+++ b/x11-libs/pango/pango-1.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.1.3.ebuild,v 1.1 2002/11/13 00:07:40 foser Exp $
+
+IUSE="doc"
+
+inherit libtool debug
+
+SLOT="1"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+
+ econf ${myconf} --without-qt || die
+ make || die "serial make failed"
+}
+
+src_install() {
+ einstall
+ rm ${D}/etc/pango/pango.modules
+
+
+ dodoc AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}
+