summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-11 12:56:22 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-11 12:56:22 +0000
commit4095c4ac1a2097836ab482dba56b91602a2db09e (patch)
tree1f9cd534caa49036be406ca1aeb92cdb6e092572 /x11-libs/qt-assistant
parentVersion bump to 4.4.1 (diff)
downloadgentoo-2-4095c4ac1a2097836ab482dba56b91602a2db09e.tar.gz
gentoo-2-4095c4ac1a2097836ab482dba56b91602a2db09e.tar.bz2
gentoo-2-4095c4ac1a2097836ab482dba56b91602a2db09e.zip
Version bump to 4.4.1
(Portage version: 2.2_rc7/cvs/Linux 2.6.26-hh1 i686)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 60dc9116153f..aea1496d2a42 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.12 2008/06/13 23:20:12 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.13 2008/08/11 12:56:22 yngwin Exp $
+
+*qt-assistant-4.4.1 (11 Aug 2008)
+
+ 11 Aug 2008; Ben de Groot <yngwin@gentoo.org> +qt-assistant-4.4.1.ebuild:
+ Version bump
13 Jun 2008; Ingmar Vanhassel <ingmar@gentoo.org>
qt-assistant-4.4.0-r1.ebuild:
diff --git a/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild
new file mode 100644
index 000000000000..b63180a84c8b
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.4.1.ebuild,v 1.1 2008/08/11 12:56:22 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-sql-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
+RDEPEND="${DEPEND}"
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries.
+QT4_TARGET_DIRECTORIES="tools/assistant tools/pixeltool"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+doc/qch/
+src/3rdparty/clucene/
+tools/shared/fontpanel"
+
+pkg_setup() {
+ qt4-build_pkg_setup
+
+ if ! built_with_use x11-libs/qt-sql sqlite; then
+ die "You must first emerge x11-libs/qt-sql with the \"sqlite\" use flag in order to use qt-assistant"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-qt3support -no-svg"
+
+ qt4-build_src_compile
+}
+
+src_install() {
+ qt4-build_src_install
+ domenu "${FILESDIR}"/Assistant.desktop || die "domenu failed"
+
+ insinto ${QTDOCDIR}
+ doins -r doc/qch/ || die 'Installing qch files failed.'
+}