summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-29 22:08:35 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-29 22:08:35 +0000
commitead547f8c63fe571bad05e953901145d9f4d4c1e (patch)
tree2ff96329513970dc53f7349d2077283d0cb17ee8 /x11-libs/qt-assistant
parentBump to 2.96, remove old later (diff)
downloadgentoo-2-ead547f8c63fe571bad05e953901145d9f4d4c1e.tar.gz
gentoo-2-ead547f8c63fe571bad05e953901145d9f4d4c1e.tar.bz2
gentoo-2-ead547f8c63fe571bad05e953901145d9f4d4c1e.zip
Version bump.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.8.1.ebuild122
2 files changed, 128 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index d24c09cb31f7..d9875b0cc995 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.124 2012/03/27 18:44:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.125 2012/03/29 22:08:35 pesa Exp $
+
+*qt-assistant-4.8.1 (29 Mar 2012)
+
+ 29 Mar 2012; Davide Pesavento <pesa@gentoo.org> +qt-assistant-4.8.1.ebuild:
+ Version bump.
27 Mar 2012; Johannes Huber <johu@gentoo.org>
-files/qt-assistant-4.6.1-tools.patch:
diff --git a/x11-libs/qt-assistant/qt-assistant-4.8.1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.8.1.ebuild
new file mode 100644
index 000000000000..0f5d5a6e4f68
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.8.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.8.1.ebuild,v 1.1 2012/03/29 22:08:35 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The Help module and Assistant application for the Qt toolkit"
+SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
+SLOT="4"
+
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="compat doc +glib qt3support trace webkit"
+
+DEPEND="
+ ~x11-libs/qt-gui-${PV}[aqua=,c++0x=,debug=,glib=,qpa=,qt3support=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,c++0x=,debug=,qpa=,qt3support=,sqlite]
+ webkit? ( ~x11-libs/qt-webkit-${PV}[aqua=,c++0x=,debug=,qpa=] )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # Pixeltool isn't really assistant related, but it relies on
+ # the assistant libraries.
+ QT4_TARGET_DIRECTORIES="
+ tools/assistant
+ tools/pixeltool
+ tools/qdoc3"
+ QT4_EXTRACT_DIRECTORIES="
+ tools
+ demos
+ examples
+ src
+ include
+ doc"
+
+ use trace && QT4_TARGET_DIRECTORIES+=" tools/qttracereplay"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ ${QT4_EXTRACT_DIRECTORIES}"
+
+ qt4-build_pkg_setup
+}
+
+src_unpack() {
+ qt4-build_src_unpack
+
+ # compat version
+ # http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
+ if use compat; then
+ unpack ${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz
+ mv "${WORKDIR}"/${PN}-qassistantclient-library-compat-version-4.6.3 \
+ "${S}"/tools/assistant/compat ||
+ die "moving compat to the right place failed"
+ tar xzf "${FILESDIR}"/${PN}-4.7-include.tar.gz -C "${S}"/include/ ||
+ die "unpacking the include files failed"
+ fi
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+
+ use compat && epatch "${FILESDIR}"/${PN}-4.7-fix-compat.patch
+
+ # bug 401173
+ use webkit || epatch "${FILESDIR}"/disable-webkit.patch
+
+ # bug 348034
+ sed -i -e '/^sub-qdoc3\.depends/d' doc/doc.pri || die
+}
+
+src_configure() {
+ myconf+="
+ -no-xkb -no-fontconfig -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-multimedia -no-svg
+ $(qt_use qt3support) $(qt_use webkit)"
+ use glib || myconf+=" -no-glib"
+
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # help libQtHelp find freshly built libQtCLucene (bug #289811)
+ export LD_LIBRARY_PATH="${S}/lib:${QTLIBDIR}"
+ export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
+
+ qt4-build_src_compile
+
+ # ugly hack to build docs
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
+
+ if use doc; then
+ emake docs
+ else
+ emake qch_docs
+ fi
+}
+
+src_install() {
+ qt4-build_src_install
+
+ emake INSTALL_ROOT="${D}" install_qchdocs
+
+ if use doc; then
+ emake INSTALL_ROOT="${D}" install_htmldocs
+ fi
+
+ dobin bin/qdoc3
+
+ doicon tools/assistant/tools/assistant/images/assistant.png
+ make_desktop_entry assistant Assistant assistant 'Qt;Development'
+
+ if use compat; then
+ insinto /usr/share/qt4/mkspecs/features
+ doins tools/assistant/compat/features/assistant.prf
+ fi
+}