summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:44:36 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-15 12:44:36 +0000
commitd425a0c7032bc90c7e61362668431780e3a62bff (patch)
tree4dccc3d26b8b72ddc55e71ef97731284e7218ba9 /x11-libs/qt-dbus
parentVersion bump to Qt-4.4.0. (diff)
downloadgentoo-2-d425a0c7032bc90c7e61362668431780e3a62bff.tar.gz
gentoo-2-d425a0c7032bc90c7e61362668431780e3a62bff.tar.bz2
gentoo-2-d425a0c7032bc90c7e61362668431780e3a62bff.zip
Version bump to Qt-4.4.0.
(Portage version: 2.1.5)
Diffstat (limited to 'x11-libs/qt-dbus')
-rw-r--r--x11-libs/qt-dbus/ChangeLog7
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.4.0.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index bdee353b7cd5..da9785de056d 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.4 2008/04/10 13:40:18 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.5 2008/05/15 12:44:36 ingmar Exp $
+
+*qt-dbus-4.4.0 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +qt-dbus-4.4.0.ebuild:
+ Version bump to Qt-4.4.0.
10 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-qt-dbus-4.4.0_beta1.ebuild, +qt-dbus-4.4.0_rc1.ebuild:
diff --git a/x11-libs/qt-dbus/qt-dbus-4.4.0.ebuild b/x11-libs/qt-dbus/qt-dbus-4.4.0.ebuild
new file mode 100644
index 000000000000..9624d38dc707
--- /dev/null
+++ b/x11-libs/qt-dbus/qt-dbus-4.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.4.0.ebuild,v 1.1 2008/05/15 12:44:36 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The DBus module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# depend on gui instead of core. There's a GUI based viewer that's built, and since it's a desktop
+# protocol I don't know if there's value trying to derive it out into a core build
+# The library itself, however, only depends on core and xml
+DEPEND="~x11-libs/qt-core-${PV}
+ >=sys-apps/dbus-1.0.2"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/dbus
+tools/qdbus/qdbus
+tools/qdbus/qdbusxml2cpp
+tools/qdbus/qdbuscpp2xml"
+QCONFIG_ADD="dbus dbus-linked"
+QCONFIG_DEFINE="QT_DBUS"
+
+#FIXME: Check if these are still needed with the header package
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtDBus/
+src/corelib/global/
+src/corelib/io/
+src/corelib/kernel/
+src/corelib/thread/
+src/corelib/tools/
+"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -dbus-linked"
+
+ qt4-build_src_compile
+}