summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-04-14 22:29:03 +0000
committerAlex Alexander <wired@gentoo.org>2011-04-14 22:29:03 +0000
commitddde1130bce1af43d06ce9996f3a0fa879f900de (patch)
tree25e6469be9f8bf3052c26563e662db70850ec09b /x11-libs/qt-declarative
parentClean up old revision. (diff)
downloadgentoo-2-ddde1130bce1af43d06ce9996f3a0fa879f900de.tar.gz
gentoo-2-ddde1130bce1af43d06ce9996f3a0fa879f900de.tar.bz2
gentoo-2-ddde1130bce1af43d06ce9996f3a0fa879f900de.zip
added webkit use flag, fixes bug #348423
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-declarative')
-rw-r--r--x11-libs/qt-declarative/ChangeLog8
-rw-r--r--x11-libs/qt-declarative/metadata.xml1
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.2-r1.ebuild64
3 files changed, 72 insertions, 1 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
index fb25f5c40204..22ef2025f518 100644
--- a/x11-libs/qt-declarative/ChangeLog
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-declarative
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.19 2011/04/13 21:04:54 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.20 2011/04/14 22:29:03 wired Exp $
+
+*qt-declarative-4.7.2-r1 (14 Apr 2011)
+
+ 14 Apr 2011; Alex Alexander <wired@gentoo.org>
+ +qt-declarative-4.7.2-r1.ebuild, metadata.xml:
+ added webkit use flag, fixes bug #348423
13 Apr 2011; Alex Alexander <wired@gentoo.org> -qt-declarative-4.7.0.ebuild,
-qt-declarative-4.7.1.ebuild, -qt-declarative-4.7.1-r1.ebuild,
diff --git a/x11-libs/qt-declarative/metadata.xml b/x11-libs/qt-declarative/metadata.xml
index be567d541229..86e2b764d474 100644
--- a/x11-libs/qt-declarative/metadata.xml
+++ b/x11-libs/qt-declarative/metadata.xml
@@ -9,6 +9,7 @@
this does not mean you can compile pure Qt3 programs with Qt4.</flag>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
+ <flag name='webkit'>Build the WebView QML element</flag>
</use>
<longdescription lang="en">
</longdescription>
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.2-r1.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.2-r1.ebuild
new file mode 100644
index 000000000000..3f07f7cefe37
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.2-r1.ebuild,v 1.1 2011/04/14 22:29:03 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="private-headers qt3support webkit"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-opengl-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-script-${PV}[aqua=]
+ ~x11-libs/qt-sql-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-svg-${PV}[aqua=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=]
+ qt3support? ( ~x11-libs/qt-qt3support-${PV}[aqua=] )
+ webkit? ( ~x11-libs/qt-webkit-${PV}[aqua=] )
+ "
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QCONFIG_ADD="declarative"
+
+ QT4_TARGET_DIRECTORIES="
+ src/declarative
+ src/imports
+ tools/designer/src/plugins/qdeclarativeview
+ tools/qml"
+
+ if use webkit; then
+ QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ src/3rdparty/webkit/WebKit/qt/declarative"
+ fi
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -declarative $(qt_use qt3support) $(qt_use webkit)"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use private-headers; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
+ # ran for the 2nd time, need it for the updated headers
+ fix_includes
+ else
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ fi
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+ fi
+}