summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 12:00:05 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 12:00:05 +0000
commitafd6f0b4d50357b905ff5424f7965ca642a4be6f (patch)
treecc1aa644f57afb19d3a6d3983a22f900056df0b8 /x11-libs/qt-gui
parentSparc stable --- Bug #238072 --- it starts and stays up, at least. (diff)
downloadgentoo-2-afd6f0b4d50357b905ff5424f7965ca642a4be6f.tar.gz
gentoo-2-afd6f0b4d50357b905ff5424f7965ca642a4be6f.tar.bz2
gentoo-2-afd6f0b4d50357b905ff5424f7965ca642a4be6f.zip
Add fix for bug 235392
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs/qt-gui')
-rw-r--r--x11-libs/qt-gui/ChangeLog6
-rw-r--r--x11-libs/qt-gui/files/qt-gui-designer-4.4.1.patch12
-rw-r--r--x11-libs/qt-gui/qt-gui-4.4.1.ebuild5
3 files changed, 21 insertions, 2 deletions
diff --git a/x11-libs/qt-gui/ChangeLog b/x11-libs/qt-gui/ChangeLog
index 87646bbd3a6d..fba9180fbb92 100644
--- a/x11-libs/qt-gui/ChangeLog
+++ b/x11-libs/qt-gui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-gui
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.14 2008/09/19 00:12:12 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.15 2008/09/19 12:00:04 yngwin Exp $
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org>
+ +files/qt-gui-designer-4.4.1.patch, qt-gui-4.4.1.ebuild:
+ Add fix for bug 235392
*qt-gui-4.4.2 (19 Sep 2008)
diff --git a/x11-libs/qt-gui/files/qt-gui-designer-4.4.1.patch b/x11-libs/qt-gui/files/qt-gui-designer-4.4.1.patch
new file mode 100644
index 000000000000..e82ab9dfb0b7
--- /dev/null
+++ b/x11-libs/qt-gui/files/qt-gui-designer-4.4.1.patch
@@ -0,0 +1,12 @@
+--- src/tools/designer/src/components/propertyeditor/propertyeditor.cpp 2008-08-14 10:25:28 -0000
++++ src/tools/designer/src/components/propertyeditor/propertyeditor.cpp 2008-08-14 10:25:28 -0000
+
+@@ -656,7 +656,7 @@
+
+ void PropertyEditor::updateColors()
+ {
+- if (m_currentBrowser == m_treeBrowser) {
++ if (m_treeBrowser && m_currentBrowser == m_treeBrowser) {
+ QList<QtBrowserItem *> items = m_treeBrowser->topLevelItems();
+ QListIterator<QtBrowserItem *> itItem(items);
+ while (itItem.hasNext()) {
diff --git a/x11-libs/qt-gui/qt-gui-4.4.1.ebuild b/x11-libs/qt-gui/qt-gui-4.4.1.ebuild
index 3a812f98ea11..84eb6b786df3 100644
--- a/x11-libs/qt-gui/qt-gui-4.4.1.ebuild
+++ b/x11-libs/qt-gui/qt-gui-4.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.4.1.ebuild,v 1.3 2008/08/16 15:07:45 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.4.1.ebuild,v 1.4 2008/09/19 12:00:04 yngwin Exp $
EAPI="1"
inherit eutils qt4-build
@@ -70,6 +70,9 @@ src_unpack() {
qt4-build_src_unpack
+ # fix for bug 235392
+ epatch "${FILESDIR}"/qt-gui-designer-4.4.1.patch
+
# Don't build plugins this go around, because they depend on qt3support lib
sed -i -e "s:CONFIG(shared:# &:g" "${S}"/tools/designer/src/src.pro
}