summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-02-15 15:10:36 +0000
committerDror Levin <spatz@gentoo.org>2010-02-15 15:10:36 +0000
commitca3bf79eaf539100d4708f2d890405947375e083 (patch)
tree8cf329ae22b58c73e1af81a3f7ee851c7f63f0f6 /x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-ca3bf79eaf539100d4708f2d890405947375e083.tar.gz
gentoo-2-ca3bf79eaf539100d4708f2d890405947375e083.tar.bz2
gentoo-2-ca3bf79eaf539100d4708f2d890405947375e083.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild')
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild b/x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild
new file mode 100644
index 000000000000..22d9cd6486b1
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.6.2.ebuild,v 1.1 2010/02/15 15:10:36 spatz Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=,qt3support=]
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/opengl
+src/plugins/graphicssystems/opengl"
+
+QT4_EXTRACT_DIRECTORIES="
+include/QtCore
+include/QtGui
+include/QtOpenGL
+src/corelib
+src/gui
+src/opengl
+src/plugins
+src/3rdparty"
+
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}