summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:08:54 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:08:54 +0000
commitdf92c9203369635192a927ab785d206a672fede6 (patch)
treed48fe9ee546b598579c8ab78fd0ef993c4dec6bd /x11-libs/qt-opengl
parentVersion bump Qt 4.7.2 (diff)
downloadgentoo-2-df92c9203369635192a927ab785d206a672fede6.tar.gz
gentoo-2-df92c9203369635192a927ab785d206a672fede6.tar.bz2
gentoo-2-df92c9203369635192a927ab785d206a672fede6.zip
Version bump Qt 4.7.2
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/ChangeLog10
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.7.2.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index 18417ab5a269..64c88897de9e 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-opengl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.83 2010/12/23 07:55:59 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.84 2011/03/01 19:08:54 tampakrap Exp $
+
+*qt-opengl-4.7.2 (01 Mar 2011)
+
+ 01 Mar 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-opengl-4.7.2.ebuild:
+ Version bump Qt 4.7.2
23 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> qt-opengl-4.6.3.ebuild:
ppc64 stable wrt #341703
diff --git a/x11-libs/qt-opengl/qt-opengl-4.7.2.ebuild b/x11-libs/qt-opengl/qt-opengl-4.7.2.ebuild
new file mode 100644
index 000000000000..a7600e4cc7e0
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.7.2.ebuild,v 1.1 2011/03/01 19:08:54 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="egl qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=,egl=,qt3support=]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/opengl
+ src/plugins/graphicssystems/opengl"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenGL
+ src/corelib
+ src/gui
+ src/opengl
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="opengl"
+ QCONFIG_DEFINE="QT_OPENGL $(use egl && echo QT_EGL)"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)
+ $(qt_use egl)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}