summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-11 13:05:52 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-11 13:05:52 +0000
commit974c3f182b81238d3209311bd4c72592fa663128 (patch)
tree6171e864ea6f4b84dc3c8f18b381e0ee597922dd /x11-libs/qt-phonon
parentVersion bumped. (diff)
downloadgentoo-2-974c3f182b81238d3209311bd4c72592fa663128.tar.gz
gentoo-2-974c3f182b81238d3209311bd4c72592fa663128.tar.bz2
gentoo-2-974c3f182b81238d3209311bd4c72592fa663128.zip
Version bump to 4.4.1
(Portage version: 2.2_rc7/cvs/Linux 2.6.26-hh1 i686)
Diffstat (limited to 'x11-libs/qt-phonon')
-rw-r--r--x11-libs/qt-phonon/ChangeLog7
-rw-r--r--x11-libs/qt-phonon/qt-phonon-4.4.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-libs/qt-phonon/ChangeLog b/x11-libs/qt-phonon/ChangeLog
index c4c60216a1d1..49c7bd383f51 100644
--- a/x11-libs/qt-phonon/ChangeLog
+++ b/x11-libs/qt-phonon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-phonon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.9 2008/06/13 23:22:53 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/ChangeLog,v 1.10 2008/08/11 13:05:52 yngwin Exp $
+
+*qt-phonon-4.4.1 (11 Aug 2008)
+
+ 11 Aug 2008; Ben de Groot <yngwin@gentoo.org> +qt-phonon-4.4.1.ebuild:
+ Version bump
13 Jun 2008; Ingmar Vanhassel <ingmar@gentoo.org> qt-phonon-4.4.0.ebuild:
Make all split Qt4 ebuilds block the old monolithic ebuild.
diff --git a/x11-libs/qt-phonon/qt-phonon-4.4.1.ebuild b/x11-libs/qt-phonon/qt-phonon-4.4.1.ebuild
new file mode 100644
index 000000000000..b10ce6df53fe
--- /dev/null
+++ b/x11-libs/qt-phonon/qt-phonon-4.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-phonon/qt-phonon-4.4.1.ebuild,v 1.1 2008/08/11 13:05:52 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The Phonon module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="dbus"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ dbus? ( =x11-libs/qt-dbus-${PV} )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/phonon
+src/plugins/phonon"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+src/3rdparty/kdelibs/phonon/
+src/3rdparty/kdebase/runtime/phonon/"
+QCONFIG_ADD="phonon"
+QCONFIG_DEFINE="QT_GSTREAMER"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -phonon -no-opengl -no-svg
+ $(qt_use dbus qdbus)"
+
+ qt4-build_src_compile
+}