summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:07:51 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:07:51 +0000
commit89f8f1caf046684f33876394d0133a379c6e37c4 (patch)
treeb2facce0f2ddc77d371868ec766c71bc56c5369e /x11-libs/qt-script
parentAdded Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled (diff)
downloadgentoo-2-89f8f1caf046684f33876394d0133a379c6e37c4.tar.gz
gentoo-2-89f8f1caf046684f33876394d0133a379c6e37c4.tar.bz2
gentoo-2-89f8f1caf046684f33876394d0133a379c6e37c4.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs/qt-script')
-rw-r--r--x11-libs/qt-script/ChangeLog12
-rw-r--r--x11-libs/qt-script/qt-script-4.4.0_beta1.ebuild30
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index d8f327945006..4b2977e2dc48 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/qt-script
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.1 2007/12/21 19:05:53 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.2 2008/03/05 23:07:51 ingmar Exp $
+
+*qt-script-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-script-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
*qt-script-4.4.0_rc1 (21 Dec 2007)
diff --git a/x11-libs/qt-script/qt-script-4.4.0_beta1.ebuild b/x11-libs/qt-script/qt-script-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..f59def2cbfac
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.4.0_beta1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:07:51 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-qdbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl"
+
+ qt4-build_src_compile
+}