summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-05-05 12:33:11 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-05-05 12:33:11 +0000
commit2b9b50c0e1aafda065043a43f95525510d3c7322 (patch)
tree932a6c70b662dcbc4c3b2a57c6e4a54110d10687 /x11-libs/qt
parentspring update, stabling 1.0.14, adding 1.0.16, fixing sqlite dep (diff)
downloadgentoo-2-2b9b50c0e1aafda065043a43f95525510d3c7322.tar.gz
gentoo-2-2b9b50c0e1aafda065043a43f95525510d3c7322.tar.bz2
gentoo-2-2b9b50c0e1aafda065043a43f95525510d3c7322.zip
Add nis support, from bug #131303
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog5
-rw-r--r--x11-libs/qt/qt-3.3.6.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 36b547966ede..34e34a8811fa 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.304 2006/04/28 00:13:53 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.305 2006/05/05 12:33:11 caleb Exp $
+
+ 05 May 2006; Caleb Tennis <caleb@gentoo.org> qt-3.3.6.ebuild:
+ Add nis support, from bug #131303
28 Apr 2006; Alec Warner <antarus@gentoo.org> files/digest-qt-4.1.1,
Manifest:
diff --git a/x11-libs/qt/qt-3.3.6.ebuild b/x11-libs/qt/qt-3.3.6.ebuild
index 648d0a70ae93..101a6c84e66e 100644
--- a/x11-libs/qt/qt-3.3.6.ebuild
+++ b/x11-libs/qt/qt-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.6.ebuild,v 1.7 2006/04/13 12:02:22 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.6.ebuild,v 1.8 2006/05/05 12:33:11 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ LICENSE="|| ( QPL-1.0 GPL-2 )"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="cups debug doc examples firebird gif ipv6 mysql nas odbc opengl postgres sqlite xinerama immqt immqt-bc"
+IUSE="cups debug doc examples firebird gif ipv6 mysql nas nis odbc opengl postgres sqlite xinerama immqt immqt-bc"
DEPEND="|| ( ( x11-libs/libXcursor
x11-libs/libXi
@@ -158,6 +158,7 @@ src_compile() {
# unixODBC support is now a PDEPEND on dev-db/qt-unixODBC; see bug 14178.
use nas && myconf="${myconf} -system-nas-sound"
+ use nis && myconf="${myconf} -nis" || myconf="${myconf} -no-nis"
use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server -I/usr/include/postgresql/pgsql -I/usr/include/postgresql/pgsql/server" || myconf="${myconf} -no-sql-psql"