summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-07-21 17:55:57 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-07-21 17:55:57 +0000
commit5de1024ec51fb38eaedf79187e9abf0da37535d3 (patch)
treec03a416858b6fc0ab7887c3aabd5dda62a89db8b /x11-libs/qwt
parentRemove old version and related files. (diff)
downloadgentoo-2-5de1024ec51fb38eaedf79187e9abf0da37535d3.tar.gz
gentoo-2-5de1024ec51fb38eaedf79187e9abf0da37535d3.tar.bz2
gentoo-2-5de1024ec51fb38eaedf79187e9abf0da37535d3.zip
adding a patch to fix compilation
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'x11-libs/qwt')
-rw-r--r--x11-libs/qwt/ChangeLog6
-rw-r--r--x11-libs/qwt/files/qwt-20060130-buildfix.patch12
-rw-r--r--x11-libs/qwt/qwt-5_pre20060130.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/x11-libs/qwt/ChangeLog b/x11-libs/qwt/ChangeLog
index 4c43598eaade..f5842abe7097 100644
--- a/x11-libs/qwt/ChangeLog
+++ b/x11-libs/qwt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qwt
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.32 2006/06/16 20:44:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/ChangeLog,v 1.33 2006/07/21 17:55:57 caleb Exp $
+
+ 21 Jul 2006; Caleb Tennis <caleb@gentoo.org>
+ +files/qwt-20060130-buildfix.patch, qwt-5_pre20060130.ebuild:
+ adding a patch to fix compilation
16 Jun 2006; Markus Rothe <corsair@gentoo.org> qwt-4.2.0-r1.ebuild:
Stable on ppc64
diff --git a/x11-libs/qwt/files/qwt-20060130-buildfix.patch b/x11-libs/qwt/files/qwt-20060130-buildfix.patch
new file mode 100644
index 000000000000..3efb2ea9b121
--- /dev/null
+++ b/x11-libs/qwt/files/qwt-20060130-buildfix.patch
@@ -0,0 +1,12 @@
+diff -ur qwt-20060130-old/include/qwt_scale_draw.h qwt-20060130/include/qwt_scale_draw.h
+--- qwt-20060130-old/include/qwt_scale_draw.h 2006-01-30 22:16:16.000000000 +0100
++++ qwt-20060130/include/qwt_scale_draw.h 2006-07-21 19:36:57.000000000 +0200
+@@ -41,7 +41,7 @@
+
+ virtual ~QwtScaleDraw();
+
+- QwtScaleDraw &QwtScaleDraw::operator=(const QwtScaleDraw &other);
++ QwtScaleDraw &operator=(const QwtScaleDraw &other);
+
+ void getBorderDistHint(const QFont &, int &start, int &end) const;
+ int minLabelDist(const QFont &) const;
diff --git a/x11-libs/qwt/qwt-5_pre20060130.ebuild b/x11-libs/qwt/qwt-5_pre20060130.ebuild
index 71d071734fc4..5bbeb3bef600 100644
--- a/x11-libs/qwt/qwt-5_pre20060130.ebuild
+++ b/x11-libs/qwt/qwt-5_pre20060130.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5_pre20060130.ebuild,v 1.2 2006/05/07 07:30:56 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwt/qwt-5_pre20060130.ebuild,v 1.3 2006/07/21 17:55:57 caleb Exp $
-inherit multilib
+inherit multilib eutils
MY_PV="${PV/5_pre/}"
@@ -22,6 +22,7 @@ DEPEND="=x11-libs/qt-4*
src_unpack () {
unpack ${A}
+ epatch ${FILESDIR}/qwt-20060130-buildfix.patch
cd ${S}
find . -type f -name "*.pro" | while read file; do
sed -e 's/.*no-exceptions.*//g' -i ${file}