summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-20 22:07:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-20 22:07:45 +0000
commit25f9c8cfe649f94f08da8ad14e1d6d5b41d71642 (patch)
tree2f108aba2564c98a31e94f081963e4095b64742c /x11-libs/vdpau-video
parentstable ppc ppc64, bug #404993 (diff)
downloadgentoo-2-25f9c8cfe649f94f08da8ad14e1d6d5b41d71642.tar.gz
gentoo-2-25f9c8cfe649f94f08da8ad14e1d6d5b41d71642.tar.bz2
gentoo-2-25f9c8cfe649f94f08da8ad14e1d6d5b41d71642.zip
Fix build with mesa opengl, bug #438180, patch ported from gstreamer-vaapi by Steven Newbury
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs/vdpau-video')
-rw-r--r--x11-libs/vdpau-video/ChangeLog7
-rw-r--r--x11-libs/vdpau-video/files/vdpau-video-0.7.4-glext-missing-definition.patch16
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/x11-libs/vdpau-video/ChangeLog b/x11-libs/vdpau-video/ChangeLog
index 68f86b4ca0c3..521fa0e0111b 100644
--- a/x11-libs/vdpau-video/ChangeLog
+++ b/x11-libs/vdpau-video/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vdpau-video
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.17 2012/10/11 12:51:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.18 2012/10/20 22:07:45 aballier Exp $
+
+ 20 Oct 2012; Alexis Ballier <aballier@gentoo.org> vdpau-video-0.7.4.ebuild,
+ +files/vdpau-video-0.7.4-glext-missing-definition.patch:
+ Fix build with mesa opengl, bug #438180, patch ported from gstreamer-vaapi by
+ Steven Newbury
*vdpau-video-0.7.4 (11 Oct 2012)
diff --git a/x11-libs/vdpau-video/files/vdpau-video-0.7.4-glext-missing-definition.patch b/x11-libs/vdpau-video/files/vdpau-video-0.7.4-glext-missing-definition.patch
new file mode 100644
index 000000000000..221b9608fe44
--- /dev/null
+++ b/x11-libs/vdpau-video/files/vdpau-video-0.7.4-glext-missing-definition.patch
@@ -0,0 +1,16 @@
+--- ./src/utils_glx.h~ 2012-10-05 16:02:58.000000000 +0100
++++ ./src/utils_glx.h 2012-10-19 08:44:12.469642440 +0100
+@@ -48,6 +48,13 @@
+ typedef void (*PFNGLXRELEASETEXIMAGEEXTPROC)(Display *, GLXDrawable, int);
+ #endif
+
++#if GL_GLEXT_VERSION >= 85
++/* XXX: PFNGLMULTITEXCOORD2FPROC got out of the GL_VERSION_1_3_DEPRECATED
++ block and is not defined if GL_VERSION_1_3 is defined in <GL/gl.h>
++ Redefine the type here as an interim solution */
++typedef void (*PFNGLMULTITEXCOORD2FPROC) (GLenum target, GLfloat s, GLfloat t);
++#endif
++
+ #ifndef GL_FRAMEBUFFER_BINDING
+ #define GL_FRAMEBUFFER_BINDING GL_FRAMEBUFFER_BINDING_EXT
+ #endif
diff --git a/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild b/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild
index 2800a1bd2017..bf812dc30d40 100644
--- a/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild
+++ b/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild,v 1.1 2012/10/11 12:51:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild,v 1.2 2012/10/20 22:07:45 aballier Exp $
EAPI="2"
-inherit autotools
+inherit autotools eutils
MY_P=libva-vdpau-driver-${PV}
DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
@@ -25,6 +25,7 @@ DEPEND="${DEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}/${P}-glext-missing-definition.patch"
eautoreconf
}