summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-15 08:30:04 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-15 08:30:04 +0000
commit92fdbef93baab2092dc55565f2b08619934c9ab1 (patch)
treec0a800103d5ef41c13776dc4c5034c2e34f2be12 /x11-libs/vte
parentSimplify ebuild a bit, and fix translation installation wrt LINGUAS. (diff)
downloadgentoo-2-92fdbef93baab2092dc55565f2b08619934c9ab1.tar.gz
gentoo-2-92fdbef93baab2092dc55565f2b08619934c9ab1.tar.bz2
gentoo-2-92fdbef93baab2092dc55565f2b08619934c9ab1.zip
Add a patch to unbreak Alt key handling with gtk+-3.2.2.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/files/vte-0.30.1-alt-meta.patch27
-rw-r--r--x11-libs/vte/vte-0.30.1-r1.ebuild55
3 files changed, 89 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index ef90300530ce..d494c84022b2 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.296 2011/10/30 17:48:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.297 2011/11/15 08:30:04 tetromino Exp $
+
+*vte-0.30.1-r1 (15 Nov 2011)
+
+ 15 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +vte-0.30.1-r1.ebuild, +files/vte-0.30.1-alt-meta.patch:
+ Add a patch to unbreak Alt key handling with gtk+-3.2.2.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> vte-0.28.2-r300.ebuild:
alpha/ia64/sh/sparc stable wrt #385699
diff --git a/x11-libs/vte/files/vte-0.30.1-alt-meta.patch b/x11-libs/vte/files/vte-0.30.1-alt-meta.patch
new file mode 100644
index 000000000000..9ea611fde51c
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.30.1-alt-meta.patch
@@ -0,0 +1,27 @@
+From 299e28dd3e5549b13ec54de991d583ac6a6ff11e Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 15 Nov 2011 03:06:40 -0500
+Subject: [PATCH] Map both gdk's Meta and Alt to vte's Meta for >=gtk+-3.2.2
+ compatibility
+
+https://bugzilla.gnome.org/show_bug.cgi?id=663779
+---
+ src/keymap.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/keymap.h b/src/keymap.h
+index 243e22e..21d9b8e 100644
+--- a/src/keymap.h
++++ b/src/keymap.h
+@@ -27,7 +27,7 @@
+
+ G_BEGIN_DECLS
+
+-#define VTE_META_MASK GDK_META_MASK
++#define VTE_META_MASK (GDK_META_MASK | GDK_MOD1_MASK)
+ #define VTE_NUMLOCK_MASK GDK_MOD2_MASK
+
+ /* Map the specified keyval/modifier setup, dependent on the mode, to either
+--
+1.7.8.rc1
+
diff --git a/x11-libs/vte/vte-0.30.1-r1.ebuild b/x11-libs/vte/vte-0.30.1-r1.ebuild
new file mode 100644
index 000000000000..b901b3835ade
--- /dev/null
+++ b/x11-libs/vte/vte-0.30.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1-r1.ebuild,v 1.1 2011/11/15 08:30:04 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME terminal widget"
+HOMEPAGE="http://git.gnome.org/browse/vte"
+
+LICENSE="LGPL-2"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade +introspection"
+
+PDEPEND="x11-libs/gnome-pty-helper"
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.1.9:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXft
+
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+pkg_setup() {
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ G2CONF="${G2CONF}
+ --disable-gnome-pty-helper
+ --disable-deprecation
+ --disable-maintainer-mode
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+}
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=663779
+ epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
+
+ gnome2_src_prepare
+}