summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-16 12:05:26 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-16 12:05:26 +0000
commitdb57d205e27be60cfae9b2328ffe2b5a22eb3182 (patch)
tree4d7202d8946d45b8e5b82ab868c2c875bd5371cd /x11-libs/vte
parentold (diff)
downloadgentoo-2-db57d205e27be60cfae9b2328ffe2b5a22eb3182.tar.gz
gentoo-2-db57d205e27be60cfae9b2328ffe2b5a22eb3182.tar.bz2
gentoo-2-db57d205e27be60cfae9b2328ffe2b5a22eb3182.zip
Version bump: Fix terminal title reporting again (CVE-2003-0070).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/vte-0.24.3.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index d139829f57cb..5a415494417f 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.252 2010/07/12 18:17:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.253 2010/07/16 12:05:26 pacho Exp $
+
+*vte-0.24.3 (16 Jul 2010)
+
+ 16 Jul 2010; Pacho Ramos <pacho@gentoo.org> +vte-0.24.3.ebuild:
+ Version bump: Fix terminal title reporting again (CVE-2003-0070).
12 Jul 2010; Jeroen Roovers <jer@gentoo.org> vte-0.22.5.ebuild:
Stable for HPPA (bug #294214).
diff --git a/x11-libs/vte/vte-0.24.3.ebuild b/x11-libs/vte/vte-0.24.3.ebuild
new file mode 100644
index 000000000000..aeadde6ec36c
--- /dev/null
+++ b/x11-libs/vte/vte-0.24.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.24.3.ebuild,v 1.1 2010/07/16 12:05:26 pacho Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade python"
+
+RDEPEND=">=dev-libs/glib-2.22.0
+ >=x11-libs/gtk+-2.14.0
+ >=x11-libs/pango-1.22.0
+ sys-libs/ncurses
+ glade? ( dev-util/glade:3 )
+ python? ( >=dev-python/pygtk-2.4 )
+ x11-libs/libX11
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecation
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable python)
+ --with-html-dir=/usr/share/doc/${PF}/html"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix ugly artifacts with upstream patches from bgo#618749
+ # FIXME: Second patch needs to be skipped since it causes problems with
+ # x11-terms/terminal, see bug #324631. If this is not solved by upstream,
+ # the problem could reappear with >=x11-libs/vte-0.25.2
+ epatch "${FILESDIR}/${PN}-0.24.1-background-color.patch"
+# epatch "${FILESDIR}/${PN}-0.24.1-background-color2.patch"
+ epatch "${FILESDIR}/${PN}-0.24.1-cleanup-background.patch"
+
+ # Prevent cursor from become invisible, bgo#602596
+ # FIXME: The following patches cannot be applied until bug #323443 is solved.
+# epatch "${FILESDIR}/${PN}-0.24.2-invisible-cursor.patch"
+# epatch "${FILESDIR}/${PN}-0.24.2-invisible-cursor2.patch"
+}