summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-10-15 03:49:51 +0000
committerAron Griffis <agriffis@gentoo.org>2006-10-15 03:49:51 +0000
commit7ce3b31bdc3e2b034152b63486beadeb13b94e06 (patch)
treea91e37e8b2131e4d3e776520113d3ef50e6f719b /x11-libs/wxGTK
parentMark 0.4.4-r8 stable on alpha (diff)
downloadgentoo-2-7ce3b31bdc3e2b034152b63486beadeb13b94e06.tar.gz
gentoo-2-7ce3b31bdc3e2b034152b63486beadeb13b94e06.tar.bz2
gentoo-2-7ce3b31bdc3e2b034152b63486beadeb13b94e06.zip
Add patch for freetype-2.2.1 API compatibility #150383
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog6
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.4.2-noftinternals.patch44
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild7
3 files changed, 55 insertions, 2 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 2223ba648700..793a58754cff 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.125 2006/09/24 12:19:30 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.126 2006/10/15 03:49:51 agriffis Exp $
+
+ 15 Oct 2006; Aron Griffis <agriffis@gentoo.org>
+ +files/wxGTK-2.4.2-noftinternals.patch, wxGTK-2.4.2-r4.ebuild:
+ Add patch for freetype-2.2.1 API compatibility #150383
24 Sep 2006; Mart Raudsepp <leio@gentoo.org> wxGTK-2.6.3.3.ebuild:
Fix typo in RDEPEND.
diff --git a/x11-libs/wxGTK/files/wxGTK-2.4.2-noftinternals.patch b/x11-libs/wxGTK/files/wxGTK-2.4.2-noftinternals.patch
new file mode 100644
index 000000000000..da21124bfba4
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.4.2-noftinternals.patch
@@ -0,0 +1,44 @@
+--- wxGTK-2.4.2/src/generic/dcpsg.cpp 2006-10-07 15:05:34.000000000 +0200
++++ wxGTK-2.4.2/src/generic/dcpsg.cpp 2006-10-07 15:08:21.000000000 +0200
+@@ -1146,7 +1146,7 @@
+ FILE *file;
+ };
+
+-static int paps_move_to( FT_Vector* to,
++static int paps_move_to( const FT_Vector* to,
+ void *user_data)
+ {
+ OutlineInfo *outline_info = (OutlineInfo*)user_data;
+@@ -1156,7 +1156,7 @@
+ return 0;
+ }
+
+-static int paps_line_to( FT_Vector* to,
++static int paps_line_to( const FT_Vector* to,
+ void *user_data)
+ {
+ OutlineInfo *outline_info = (OutlineInfo*)user_data;
+@@ -1166,8 +1166,8 @@
+ return 0;
+ }
+
+-static int paps_conic_to( FT_Vector* control,
+- FT_Vector* to,
++static int paps_conic_to( const FT_Vector* control,
++ const FT_Vector* to,
+ void *user_data)
+ {
+ OutlineInfo *outline_info = (OutlineInfo*)user_data;
+@@ -1179,9 +1179,9 @@
+ return 0;
+ }
+
+-static int paps_cubic_to( FT_Vector* control1,
+- FT_Vector* control2,
+- FT_Vector* to,
++static int paps_cubic_to( const FT_Vector* control1,
++ const FT_Vector* control2,
++ const FT_Vector* to,
+ void *user_data)
+ {
+ OutlineInfo *outline_info = (OutlineInfo*)user_data;
diff --git a/x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild b/x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild
index af4c0ad68050..3bc4c17cf7b2 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild,v 1.6 2006/02/13 06:51:33 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2-r4.ebuild,v 1.7 2006/10/15 03:49:51 agriffis Exp $
inherit flag-o-matic eutils gnuconfig multilib toolchain-funcs
@@ -46,6 +46,11 @@ src_unpack() {
# gcc 4 compile patch ; bug #117357
epatch "${FILESDIR}"/${P}-gcc4.patch
+ # freetype-2.2.1 compile patch #150383
+ if has_version '>=media-libs/freetype-2.2.1'; then
+ epatch ${FILESDIR}/${PN}-2.4.2-noftinternals.patch
+ fi
+
gnuconfig_update
}