summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-03-27 06:07:11 +0000
committerMamoru Komachi <usata@gentoo.org>2005-03-27 06:07:11 +0000
commitf759dc968a03ee415cb818b54f82fb5bdeef2d29 (patch)
treecbcb71bf3e2efc2b6477bedd1b43a539a4b5b4d3 /x11-libs/xforms/xforms-1.0-r1.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-f759dc968a03ee415cb818b54f82fb5bdeef2d29.tar.gz
gentoo-2-f759dc968a03ee415cb818b54f82fb5bdeef2d29.tar.bz2
gentoo-2-f759dc968a03ee415cb818b54f82fb5bdeef2d29.zip
Added cjk patch from CJK-LyX site.
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-libs/xforms/xforms-1.0-r1.ebuild')
-rw-r--r--x11-libs/xforms/xforms-1.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/xforms/xforms-1.0-r1.ebuild b/x11-libs/xforms/xforms-1.0-r1.ebuild
new file mode 100644
index 000000000000..ad6fa8fe9685
--- /dev/null
+++ b/x11-libs/xforms/xforms-1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0-r1.ebuild,v 1.1 2005/03/27 06:07:11 usata Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}-release
+DESCRIPTION="A graphical user interface toolkit for X"
+HOMEPAGE="http://world.std.com/~xforms/"
+SRC_URI="ftp://ncmir.ucsd.edu/pub/xforms/OpenSource/${P}-release.tgz
+ cjk? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/${P}-i18n_7.patch )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+IUSE="cjk"
+
+PROVIDE="virtual/xforms"
+
+src_unpack() {
+ unpack ${P}-release.tgz
+ cd ${WORKDIR}/${P}-release
+
+ use cjk && epatch ${DISTDIR}/${P}-i18n_7.patch
+
+ # use custom CFLAGS
+ sed -i -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Imakefile
+}
+
+src_compile() {
+ xmkmf -a
+ sed -i -e s/'demos$'// Makefile
+
+ # use custom CFLAGS
+ sed -i -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Makefile
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}