summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-01-08 09:32:05 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-01-08 09:32:05 +0000
commitfb1cbf57fc599b60ed126ec781389c19706048e9 (patch)
tree90ff5b9a71264e061b0e4174ecc618bb9f07c6cc /x11-libs/xosd
parentCloses #13466 (diff)
downloadgentoo-2-fb1cbf57fc599b60ed126ec781389c19706048e9.tar.gz
gentoo-2-fb1cbf57fc599b60ed126ec781389c19706048e9.tar.bz2
gentoo-2-fb1cbf57fc599b60ed126ec781389c19706048e9.zip
Moved xmms-xosd function to xosd.
Diffstat (limited to 'x11-libs/xosd')
-rw-r--r--x11-libs/xosd/ChangeLog8
-rw-r--r--x11-libs/xosd/files/configure-gentoo.diff150
-rw-r--r--x11-libs/xosd/files/digest-xosd-2.0.1-r11
-rw-r--r--x11-libs/xosd/xosd-2.0.1-r1.ebuild43
4 files changed, 201 insertions, 1 deletions
diff --git a/x11-libs/xosd/ChangeLog b/x11-libs/xosd/ChangeLog
index 25bce4335c11..5056ae8ef8d2 100644
--- a/x11-libs/xosd/ChangeLog
+++ b/x11-libs/xosd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/xosd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/ChangeLog,v 1.11 2002/12/19 18:06:13 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/ChangeLog,v 1.12 2003/01/08 09:32:05 aliz Exp $
+
+*xosd-2.0.1-r1 (07 Jan 2003)
+
+ 07 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> xosd-2.0.1-r1.ebuild :
+ Fix for #12519. Moved installation of xmms plugin to this ebuild instead of media-plugins/xmms-xosd.
+ Fixed installation function.
*xosd-2.0.1 (19 Dec 2002)
diff --git a/x11-libs/xosd/files/configure-gentoo.diff b/x11-libs/xosd/files/configure-gentoo.diff
new file mode 100644
index 000000000000..eacb868364e8
--- /dev/null
+++ b/x11-libs/xosd/files/configure-gentoo.diff
@@ -0,0 +1,150 @@
+--- /tmp/configure 2003-01-07 14:01:03.000000000 +0100
++++ configure 2003-01-07 14:08:33.000000000 +0100
+@@ -7021,19 +7021,19 @@
+
+ SELECTED_PLUGINS=
+
+-# Extract the first word of "xmms-config", so it can be a program name with args.
+-set dummy xmms-config; ac_word=$2
++# Extract the first word of "gdk-pixbuf-config", so it can be a program name with args.
++set dummy gdk-pixbuf-config; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+-echo "configure:7028: checking for $ac_word" >&5
+-if eval "test \"`echo '$''{'ac_cv_path_xmms_config_script'+set}'`\" = set"; then
++echo "configure:7083: checking for $ac_word" >&5
++if eval "test \"`echo '$''{'ac_cv_path_gdk_pixbuf_config_script'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+- case "$xmms_config_script" in
++ case "$gdk_pixbuf_config_script" in
+ /*)
+- ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a path.
++ ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a path.
+ ;;
+ ?:/*)
+- ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a dos path.
++ ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a dos path.
+ ;;
+ *)
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
+@@ -7041,54 +7041,37 @@
+ for ac_dir in $ac_dummy; do
+ test -z "$ac_dir" && ac_dir=.
+ if test -f $ac_dir/$ac_word; then
+- ac_cv_path_xmms_config_script="$ac_dir/$ac_word"
++ ac_cv_path_gdk_pixbuf_config_script="$ac_dir/$ac_word"
+ break
+ fi
+ done
+ IFS="$ac_save_ifs"
+- test -z "$ac_cv_path_xmms_config_script" && ac_cv_path_xmms_config_script=""none""
++ test -z "$ac_cv_path_gdk_pixbuf_config_script" && ac_cv_path_gdk_pixbuf_config_script=""none""
+ ;;
+ esac
+ fi
+-xmms_config_script="$ac_cv_path_xmms_config_script"
+-if test -n "$xmms_config_script"; then
+- echo "$ac_t""$xmms_config_script" 1>&6
++gdk_pixbuf_config_script="$ac_cv_path_gdk_pixbuf_config_script"
++if test -n "$gdk_pixbuf_config_script"; then
++ echo "$ac_t""$gdk_pixbuf_config_script" 1>&6
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+
+-if test "x$xmms_config_script" = "xnone" ; then
+- echo "*** xmms-config script not found. xmms plugin will not be built"
+-else
+- XMMS_CFLAGS=`$xmms_config_script --cflags`
+- XMMS_LIBS=`$xmms_config_script --libs`
+- echo $ac_n "checking for xmms plugin directory""... $ac_c" 1>&6
+-echo "configure:7067: checking for xmms plugin directory" >&5
+- if test "x$XMMS_PLUGIN_DIR" = "x" ; then
+- XMMS_PLUGIN_DIR=`$xmms_config_script --general-plugin-dir`
+- fi
+- echo "$ac_t""$XMMS_PLUGIN_DIR" 1>&6
+-
+-
+-
+- SELECTED_PLUGINS="$SELECTED_PLUGINS xmms_plugin"
+-fi
+
+
+-
+-# Extract the first word of "gdk-pixbuf-config", so it can be a program name with args.
+-set dummy gdk-pixbuf-config; ac_word=$2
++# Extract the first word of "xmms-config", so it can be a program name with args.
++set dummy xmms-config; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+-echo "configure:7083: checking for $ac_word" >&5
+-if eval "test \"`echo '$''{'ac_cv_path_gdk_pixbuf_config_script'+set}'`\" = set"; then
++echo "configure:7028: checking for $ac_word" >&5
++if eval "test \"`echo '$''{'ac_cv_path_xmms_config_script'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+- case "$gdk_pixbuf_config_script" in
++ case "$xmms_config_script" in
+ /*)
+- ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a path.
++ ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a path.
+ ;;
+ ?:/*)
+- ac_cv_path_gdk_pixbuf_config_script="$gdk_pixbuf_config_script" # Let the user override the test with a dos path.
++ ac_cv_path_xmms_config_script="$xmms_config_script" # Let the user override the test with a dos path.
+ ;;
+ *)
+ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
+@@ -7096,24 +7079,46 @@
+ for ac_dir in $ac_dummy; do
+ test -z "$ac_dir" && ac_dir=.
+ if test -f $ac_dir/$ac_word; then
+- ac_cv_path_gdk_pixbuf_config_script="$ac_dir/$ac_word"
++ ac_cv_path_xmms_config_script="$ac_dir/$ac_word"
+ break
+ fi
+ done
+ IFS="$ac_save_ifs"
+- test -z "$ac_cv_path_gdk_pixbuf_config_script" && ac_cv_path_gdk_pixbuf_config_script=""none""
++ test -z "$ac_cv_path_xmms_config_script" && ac_cv_path_xmms_config_script=""none""
+ ;;
+ esac
+ fi
+-gdk_pixbuf_config_script="$ac_cv_path_gdk_pixbuf_config_script"
+-if test -n "$gdk_pixbuf_config_script"; then
+- echo "$ac_t""$gdk_pixbuf_config_script" 1>&6
++xmms_config_script="$ac_cv_path_xmms_config_script"
++if test -n "$xmms_config_script"; then
++ echo "$ac_t""$xmms_config_script" 1>&6
+ else
+ echo "$ac_t""no" 1>&6
+ fi
+
+-GDK_PIXBUF_CFLAGS=`$gdk_pixbuf_config_script --cflags`
+-GDK_PIXBUF_LIBS=`$gdk_pixbuf_config_script --libs`
++if test "x$xmms_config_script" = "xnone" || test "x$gdk_pixbuf_config_script" = "xnone" ; then
++ echo "*** xmms-config script not found. xmms plugin will not be built"
++else
++ XMMS_CFLAGS=`$xmms_config_script --cflags`
++ XMMS_LIBS=`$xmms_config_script --libs`
++
++ GDK_PIXBUF_CFLAGS=`$gdk_pixbuf_config_script --cflags`
++ GDK_PIXBUF_LIBS=`$gdk_pixbuf_config_script --libs`
++
++ echo $ac_n "checking for xmms plugin directory""... $ac_c" 1>&6
++ echo "configure:7067: checking for xmms plugin directory" >&5
++ if test "x$XMMS_PLUGIN_DIR" = "x" ; then
++ XMMS_PLUGIN_DIR=`$xmms_config_script --general-plugin-dir`
++ fi
++ echo "$ac_t""$XMMS_PLUGIN_DIR" 1>&6
++
++
++
++ SELECTED_PLUGINS="$SELECTED_PLUGINS xmms_plugin"
++fi
++
++
++
++
+
+
+
diff --git a/x11-libs/xosd/files/digest-xosd-2.0.1-r1 b/x11-libs/xosd/files/digest-xosd-2.0.1-r1
new file mode 100644
index 000000000000..2bf7c451beed
--- /dev/null
+++ b/x11-libs/xosd/files/digest-xosd-2.0.1-r1
@@ -0,0 +1 @@
+MD5 5dd27d1753f639c44c87df0f0de0eae5 xosd-2.0.1.tar.gz 242579
diff --git a/x11-libs/xosd/xosd-2.0.1-r1.ebuild b/x11-libs/xosd/xosd-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..d7479a3370ff
--- /dev/null
+++ b/x11-libs/xosd/xosd-2.0.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/xosd-2.0.1-r1.ebuild,v 1.1 2003/01/08 09:32:05 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Library for overlaying text/glyphs in X-Windows \
+X-On-Screen-Display plus binary for sending text from command line."
+HOMEPAGE="http://www.ignavus.net/"
+SRC_URI="http://www.ignavus.net/${P}.tar.gz"
+
+IUSE="xmms"
+DEPEND="virtual/x11
+ xmms? ( media-sound/xmms
+ media-libs/gdk-pixbuf )"
+RDEPEND=${DEPEND}
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ patch -p0 < ${FILESDIR}/configure-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+
+ if [ "`use xmms`" ]; then
+ myconf="--with-plugindir=/usr/lib/xmms"
+ else
+ myconf="--without-plugindir"
+ fi
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS COPYING README
+}