summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-10-28 17:31:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-10-28 17:31:23 +0000
commit5c95b785b81ec4f55263b1f7692d2ca57513224c (patch)
tree60dc268623bb879b39b4679a8b009856bd5a51d3 /x11-libs/xpa
parentVersion bump (diff)
downloadgentoo-2-5c95b785b81ec4f55263b1f7692d2ca57513224c.tar.gz
gentoo-2-5c95b785b81ec4f55263b1f7692d2ca57513224c.tar.bz2
gentoo-2-5c95b785b81ec4f55263b1f7692d2ca57513224c.zip
Version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'x11-libs/xpa')
-rw-r--r--x11-libs/xpa/ChangeLog9
-rw-r--r--x11-libs/xpa/xpa-2.1.15.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/x11-libs/xpa/ChangeLog b/x11-libs/xpa/ChangeLog
index 2a4617e3e3a4..839c1e255240 100644
--- a/x11-libs/xpa/ChangeLog
+++ b/x11-libs/xpa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xpa
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.10 2012/07/04 20:29:20 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.11 2013/10/28 17:31:23 bicatali Exp $
+
+*xpa-2.1.15 (28 Oct 2013)
+
+ 28 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> +xpa-2.1.15.ebuild:
+ Version bump
*xpa-2.1.14 (04 Jul 2012)
diff --git a/x11-libs/xpa/xpa-2.1.15.ebuild b/x11-libs/xpa/xpa-2.1.15.ebuild
new file mode 100644
index 000000000000..a8d5075ca32c
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.15.ebuild,v 1.1 2013/10/28 17:31:23 bicatali Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="http://hea-www.harvard.edu/RD/xpa/"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="dev-lang/tcl
+ x11-libs/libXt
+ !<sci-astronomy/ds9-5.3"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib || die
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa
+}
+
+src_install () {
+ dodir /usr/$(get_libdir)
+ emake INSTALL_ROOT="${D}" install
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+ "${ED}"/usr/$(get_libdir)/tclxpa/ || die
+ dodoc README
+ use doc && dodoc doc/*.pdf && dohtml doc/*.html
+ # build system so crappy not worth patching to a non respondant upstream
+ # and builds static with PIC
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}