summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-04 20:29:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-04 20:29:20 +0000
commitac412870f79a4a0b78dcbac9edd2862c98b53565 (patch)
treea0de95dcaacbb0cf936bdbedeaada287158c6aa7 /x11-libs/xpa
parentVersion bump. (diff)
downloadgentoo-2-ac412870f79a4a0b78dcbac9edd2862c98b53565.tar.gz
gentoo-2-ac412870f79a4a0b78dcbac9edd2862c98b53565.tar.bz2
gentoo-2-ac412870f79a4a0b78dcbac9edd2862c98b53565.zip
Version bump
(Portage version: 2.1.11.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/xpa')
-rw-r--r--x11-libs/xpa/ChangeLog10
-rw-r--r--x11-libs/xpa/xpa-2.1.14.ebuild54
2 files changed, 61 insertions, 3 deletions
diff --git a/x11-libs/xpa/ChangeLog b/x11-libs/xpa/ChangeLog
index 639e95f74e1e..2a4617e3e3a4 100644
--- a/x11-libs/xpa/ChangeLog
+++ b/x11-libs/xpa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xpa
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.9 2011/08/05 20:58:18 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/ChangeLog,v 1.10 2012/07/04 20:29:20 bicatali Exp $
+
+*xpa-2.1.14 (04 Jul 2012)
+
+ 04 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +xpa-2.1.14.ebuild:
+ Version bump
05 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> xpa-2.1.13.ebuild:
Added static-libs. Simplified ebuild for EAPI4
@@ -42,4 +47,3 @@
+files/xpa-2.1.8-ds9-5.4.patch, +files/xpa-2.1.8-makefile.patch,
+metadata.xml, +xpa-2.1.8.ebuild:
Initial import
-
diff --git a/x11-libs/xpa/xpa-2.1.14.ebuild b/x11-libs/xpa/xpa-2.1.14.ebuild
new file mode 100644
index 000000000000..d9753d7e3527
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xpa/xpa-2.1.14.ebuild,v 1.1 2012/07/04 20:29:20 bicatali Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="http://hea-www.harvard.edu/RD/xpa/"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="dev-lang/tcl
+ x11-libs/libXt
+ !<sci-astronomy/ds9-5.3"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib || die
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa
+}
+
+src_install () {
+ dodir /usr/$(get_libdir)
+ emake INSTALL_ROOT="${D}" install
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+ "${ED}"/usr/$(get_libdir)/tclxpa/ || die
+ dodoc README
+ use doc && dodoc doc/*.pdf && dohtml doc/*.html
+ # build system so crappy not worth patching to a non respondant upstream
+ # and builds static with PIC
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}