summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 17:58:23 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 17:58:23 +0000
commit104283017f6e56c4cd882fab1eb60a633e5fb99c (patch)
tree3000be749acb2232161eda7a75c52c0ae5f41751 /x11-libs
parentfix ChangeLog header (diff)
downloadgentoo-2-104283017f6e56c4cd882fab1eb60a633e5fb99c.tar.gz
gentoo-2-104283017f6e56c4cd882fab1eb60a633e5fb99c.tar.bz2
gentoo-2-104283017f6e56c4cd882fab1eb60a633e5fb99c.zip
Add check for qt-core built with use ssl, to fix bug 236781
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog5
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild6
2 files changed, 9 insertions, 2 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index ac30bdbc638f..84c0420c1e2d 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.12 2008/09/19 00:18:17 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.13 2008/09/19 17:58:23 yngwin Exp $
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org> qt-webkit-4.4.2.ebuild:
+ Add check for qt-core built with use ssl, to fix bug 236781
*qt-webkit-4.4.2 (19 Sep 2008)
diff --git a/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
index 8445a55af0a0..4432c0f7e72f 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild,v 1.1 2008/09/19 00:18:17 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.4.2.ebuild,v 1.2 2008/09/19 17:58:23 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -23,6 +23,10 @@ tools/designer/src/plugins/qwebview"
QCONFIG_ADD="webkit"
QCONFIG_DEFINE="QT_WEBKIT"
+# see bug 236781
+QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} ssl"
+
src_compile() {
local myconf
myconf="${myconf} -webkit"