summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-27 19:23:40 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-27 19:23:40 +0000
commit1ce866b7ed93942c0d06bd938c82caf1c1958537 (patch)
treeee5f482f94c47aa5c9a33830e905d317ae8dac59 /x11-libs
parentQt 4.5.2 release version bump (diff)
downloadgentoo-2-1ce866b7ed93942c0d06bd938c82caf1c1958537.tar.gz
gentoo-2-1ce866b7ed93942c0d06bd938c82caf1c1958537.tar.bz2
gentoo-2-1ce866b7ed93942c0d06bd938c82caf1c1958537.zip
Qt 4.5.2 release version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog7
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 0fed1c14e0fc..aede3c798218 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.43 2009/06/06 08:40:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.44 2009/06/27 19:23:40 yngwin Exp $
+
+*qt-webkit-4.5.2 (27 Jun 2009)
+
+ 27 Jun 2009; Ben de Groot <yngwin@gentoo.org> +qt-webkit-4.5.2.ebuild:
+ Version bump
06 Jun 2009; Markus Meier <maekke@gentoo.org> qt-webkit-4.5.1.ebuild:
amd64 stable, bug #266201
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.2.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.2.ebuild
new file mode 100644
index 000000000000..3096374ccde7
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.2.ebuild,v 1.1 2009/06/27 19:23:40 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build flag-o-matic
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd"
+IUSE="kde"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[debug=]
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[debug=] media-sound/phonon ) )
+ kde? ( media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ # This fixes relocation overflows on alpha
+ use alpha && append-ldflags "-Wl,--no-relax"
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}