summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-03-06 20:34:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-03-06 20:34:11 +0000
commit26a725499b3d6d7efef38ba1233efb0b9940bcb5 (patch)
treec254d1603ffc999b434b5aa4309c8f8831bef1df /x11-libs
parentVersion bump (diff)
downloadgentoo-2-26a725499b3d6d7efef38ba1233efb0b9940bcb5.tar.gz
gentoo-2-26a725499b3d6d7efef38ba1233efb0b9940bcb5.tar.bz2
gentoo-2-26a725499b3d6d7efef38ba1233efb0b9940bcb5.zip
Version bump. Bug #502134
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfm/ChangeLog8
-rw-r--r--x11-libs/libfm/libfm-1.2.0.ebuild119
-rw-r--r--x11-libs/libfm/libfm-9999.ebuild6
3 files changed, 129 insertions, 4 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index d2e0d2a2fcf5..6b28eff53632 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.97 2014/03/05 18:32:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.98 2014/03/06 20:34:11 hwoarang Exp $
+
+*libfm-1.2.0 (06 Mar 2014)
+
+ 06 Mar 2014; Markos Chandras <hwoarang@gentoo.org> +libfm-1.2.0.ebuild,
+ libfm-9999.ebuild:
+ Version bump. Bug #502134
05 Mar 2014; Agostino Sarubbo <ago@gentoo.org> libfm-1.1.4.ebuild:
Stable for ppc, wrt bug #494440
diff --git a/x11-libs/libfm/libfm-1.2.0.ebuild b/x11-libs/libfm/libfm-1.2.0.ebuild
new file mode 100644
index 000000000000..5bdc098ddae4
--- /dev/null
+++ b/x11-libs/libfm/libfm-1.2.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-1.2.0.ebuild,v 1.1 2014/03/06 20:34:11 hwoarang Exp $
+
+EAPI=5
+
+inherit autotools fdo-mime vala
+
+MY_PV=${PV/_/}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.xz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+SLOT="0/4.0.0" #copy ABI_VERSION because it seems upstream change it randomly
+IUSE="+automount debug doc examples udisks vala"
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ >=lxde-base/menu-cache-0.3.2:="
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ automount? (
+ udisks? ( || (
+ gnome-base/gvfs[udev,udisks]
+ gnome-base/gvfs[udev,gdu]
+ ) )
+ !udisks? ( gnome-base/gvfs[udev] )
+ )"
+DEPEND="${COMMON_DEPEND}
+ vala? ( $(vala_depend) )
+ doc? (
+ dev-util/gtk-doc
+ )
+ app-arch/xz-utils
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}"/${MY_P}
+
+REQUIRED_USE="udisks? ( automount )"
+
+src_prepare() {
+ if ! use doc; then
+ sed -ie '/^SUBDIR.*=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
+ fi
+ sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
+ configure.ac || die "sed failed"
+
+ #disable unused translations. Bug #356029
+ for trans in app-chooser ask-rename exec-file file-prop preferred-apps \
+ progress;do
+ echo "data/ui/"${trans}.ui >> po/POTFILES.in
+ done
+ #Remove -Werror for automake-1.12. Bug #421101
+ sed -i "s:-Werror::" configure.ac || die
+
+ # subslot sanity check
+ local sub_slot=${SLOT#*/}
+ local libfm_major_abi=$(sed -rne '/ABI_VERSION/s:.*=::p' src/Makefile.am | tr ':' '.')
+
+ if [[ ${sub_slot} != ${libfm_major_abi} ]]; then
+ eerror "Ebuild sub-slot (${sub_slot}) does not match ABI_VERSION(${libfm_major_abi})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${libfm_major_abi}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ eautoreconf
+ rm -r autom4te.cache || die
+ use vala && export VALAC="$(type -p valac-$(vala_best_api_version))"
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc" \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable examples demo) \
+ $(use_enable debug) \
+ $(use_enable udisks) \
+ $(use_enable vala actions) \
+ $(use_enable doc gtk-doc) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+ # Sometimes a directory is created instead of a symlink. No idea why...
+ # It is wrong anyway. We expect a libfm-1.0 directory and then a libfm
+ # symlink to it.
+ if [[ -h ${D}/usr/include/${PN} || -d ${D}/usr/include/${PN} ]]; then
+ rm -r "${D}"/usr/include/${PN}
+ fi
+}
+
+pkg_preinst() {
+ # Resolve the symlink mess. Bug #439570
+ [[ -d "${ROOT}"/usr/include/${PN} ]] && \
+ rm -rf "${ROOT}"/usr/include/${PN}
+ if [[ -d "${D}"/usr/include/${PN}-1.0 ]]; then
+ cd "${D}"/usr/include
+ ln -s --force ${PN}-1.0 ${PN}
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
diff --git a/x11-libs/libfm/libfm-9999.ebuild b/x11-libs/libfm/libfm-9999.ebuild
index 1a91a5ddbbe0..97035555eea3 100644
--- a/x11-libs/libfm/libfm-9999.ebuild
+++ b/x11-libs/libfm/libfm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-9999.ebuild,v 1.38 2014/02/07 22:43:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-9999.ebuild,v 1.39 2014/03/06 20:34:11 hwoarang Exp $
EAPI=5
@@ -13,7 +13,7 @@ DESCRIPTION="A library for file management"
HOMEPAGE="http://pcmanfm.sourceforge.net/"
LICENSE="GPL-2"
-SLOT="0/4.7.1" #copy ABI_VERSION because it seems upstream change it randomly
+SLOT="0/4.0.0" #copy ABI_VERSION because it seems upstream change it randomly
IUSE="+automount debug doc examples udisks vala"
KEYWORDS=""
@@ -44,7 +44,7 @@ REQUIRED_USE="udisks? ( automount )"
src_prepare() {
if ! use doc; then
- sed -ie '/SUBDIRS=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -ie '/^SUBDIR.*=/s#docs##' "${S}"/Makefile.am || die "sed failed"
sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
else
gtkdocize --copy || die