summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-06-28 13:59:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-06-28 13:59:01 +0000
commit43e24d5cc76db9bdaf8f86c9e565f70ef4bdd584 (patch)
treec17207d385ff635311b7675677ac7af0bd143aa5 /x11-libs
parentFinal release of Qt4 (diff)
downloadgentoo-2-43e24d5cc76db9bdaf8f86c9e565f70ef4bdd584.tar.gz
gentoo-2-43e24d5cc76db9bdaf8f86c9e565f70ef4bdd584.tar.bz2
gentoo-2-43e24d5cc76db9bdaf8f86c9e565f70ef4bdd584.zip
remove snapshot
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/files/digest-qt-4.0.0_rc1-r31
-rw-r--r--x11-libs/qt/files/qt4rc1_nomkdir.patch19
-rw-r--r--x11-libs/qt/qt-4.0.0_rc1-r3.ebuild190
3 files changed, 0 insertions, 210 deletions
diff --git a/x11-libs/qt/files/digest-qt-4.0.0_rc1-r3 b/x11-libs/qt/files/digest-qt-4.0.0_rc1-r3
deleted file mode 100644
index 4ef65517c56d..000000000000
--- a/x11-libs/qt/files/digest-qt-4.0.0_rc1-r3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 324cb375b974cbbd472f3dc247d7893f qt-x11-opensource-desktop-4.0.0-snapshot-20050620.tar.bz2 15655155
diff --git a/x11-libs/qt/files/qt4rc1_nomkdir.patch b/x11-libs/qt/files/qt4rc1_nomkdir.patch
deleted file mode 100644
index 97ba71085e5a..000000000000
--- a/x11-libs/qt/files/qt4rc1_nomkdir.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig 2005-06-03 13:38:58.316152040 -0500
-+++ configure 2005-06-03 13:39:36.673320864 -0500
-@@ -1071,16 +1071,6 @@
- [ -z "$QT_INSTALL_TRANSLATIONS" ] && QT_INSTALL_TRANSLATIONS=$QT_INSTALL_PREFIX/translations #default
- QT_INSTALL_TRANSLATIONS=`$relpath/config.tests/unix/makeabs "$QT_INSTALL_TRANSLATIONS"`
-
--#settings
--if [ "$PLATFORM_MAC" = "yes" ]; then
-- [ -z "$QT_INSTALL_SETTINGS" ] && QT_INSTALL_SETTINGS=/Library/Preferences/Qt #default
--else
-- [ -z "$QT_INSTALL_SETTINGS" ] && QT_INSTALL_SETTINGS=/etc/xdg #default
--fi
--if mkdir -p "$QT_INSTALL_SETTINGS" >/dev/null 2>&1; then
-- QT_INSTALL_SETTINGS=`(cd "$QT_INSTALL_SETTINGS"; /bin/pwd)` #absolute
--fi
--
- #examples
- [ -z "$QT_INSTALL_EXAMPLES" ] && QT_INSTALL_EXAMPLES=$QT_INSTALL_PREFIX/examples #default
- QT_INSTALL_EXAMPLES=`$relpath/config.tests/unix/makeabs "$QT_INSTALL_EXAMPLES"`
diff --git a/x11-libs/qt/qt-4.0.0_rc1-r3.ebuild b/x11-libs/qt/qt-4.0.0_rc1-r3.ebuild
deleted file mode 100644
index 90cdc4d050ef..000000000000
--- a/x11-libs/qt/qt-4.0.0_rc1-r3.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.0_rc1-r3.ebuild,v 1.1 2005/06/20 20:01:59 caleb Exp $
-
-inherit eutils flag-o-matic
-
-SRCTYPE="opensource-desktop"
-SNAPSHOT="20050620"
-#SNAPSHOT=""
-DESCRIPTION="QT version ${PV}"
-HOMEPAGE="http://www.trolltech.com/"
-
-SRC_URI="ftp://ftp.trolltech.com/qt/snapshots/qt-x11-${SRCTYPE}-${PV/_rc1/}-snapshot-${SNAPSHOT}.tar.bz2"
-#SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV/_rc1/-rc1}.tar.bz2"
-#S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV/_rc1/-rc1}
-S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV/_rc1/}-snapshot-${SNAPSHOT}
-
-LICENSE="|| ( QPL-1.0 GPL-2 )"
-SLOT="4"
-KEYWORDS="-*"
-IUSE="accessibility cups debug doc examples firebird gif ipv6 jpeg mng mysql nas nis odbc opengl postgres png sqlite xinerama zlib"
-
-DEPEND="virtual/x11 virtual/xft >=media-libs/freetype-2
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- mng? ( media-libs/libmng )
- nas? ( >=media-libs/nas-1.5 )
- odbc? ( dev-db/unixODBC )
- mysql? ( dev-db/mysql )
- firebird? ( dev-db/firebird )
- opengl? ( virtual/opengl virtual/glu )
- postgres? ( dev-db/postgresql )
- cups? ( net-print/cups )
- zlib? ( sys-libs/zlib )"
-
-pkg_setup() {
- QTBASEDIR=/usr/$(get_libdir)/qt4
- QTPREFIXDIR=/usr/$(get_libdir)/qt4
- QTBINDIR=/usr/bin
- QTLIBDIR=/usr/$(get_libdir)/qt4
- QTDATADIR=/usr/share/qt4
- QTDOCDIR=${QTDATADIR}/doc
- QTHEADERDIR=/usr/include/qt4
- QTPLUGINDIR=${QTLIBDIR}/plugins
- QTSYSCONFDIR=/etc/qt4
- QTTRANSDIR=${QTDATADIR}/translations
- QTEXAMPLESDIR=${QTDATADIR}/examples
- QTDEMOSDIR=${QTDATADIR}/demos
-
- PLATFORM=$(qt_mkspecs_dir)
-}
-
-qt_use() {
- useq ${1} && echo "-${1}" || echo "-no-${1}"
- return 0
-}
-
-qt_mkspecs_dir() {
- # Allows us to define which mkspecs dir we want to use. Currently we only use
- # linux-g++ or linux-g++-64, but others could be used for various platforms.
-
- if [[ $(get_libdir) == "lib" ]]; then
- echo "linux-g++"
- else
- echo "linux-g++-64"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- cp configure configure.orig
- sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
-
- cd mkspecs/$(qt_mkspecs_dir)
- # set c/xxflags and ldflags
-
- # Don't let the user go too overboard with flags. If you really want to, uncomment
- # out the line below and give 'er a whirl.
- strip-flags
- replace-flags -O3 -O2
-
- sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
- -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
- -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
- qmake.conf
- cd ${S}
-
- epatch ${FILESDIR}/qt4-rpath.patch
- epatch ${FILESDIR}/qt4rc1_nomkdir.patch
-
- sed -i -e "s:CFG_REDUCE_EXPORTS=auto:CFG_REDUCE_EXPORTS=no:" configure
-}
-
-src_compile() {
- export SYSCONF=${D}${QTPREFIXDIR}/etc/settings
- export PATH="${S}/bin:${PATH}"
- export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
-
- # Fixes for 89704
- export LC_ALL=C
- export LANG=C
-
- # Let's just allow writing to these directories during Qt emerge
- # as it makes Qt much happier.
- # addwrite "${QTBASE}/etc/settings"
- # addwrite "$HOME/.qt"
-
- myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
- myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
- use png && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
- use jpeg && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
- use debug && myconf="${myconf} -debug-and-release" || myconf="${myconf} -release"
- use zlib && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
-
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
- use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
- use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
- use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
-
- myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
-
- ./configure -stl -verbose -largefile \
- -platform ${PLATFORM} -xplatform ${PLATFORM} \
- -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
- -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
- -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} \
- -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR} ${myconf} || die
-
- emake sub-tools-all-ordered || die
- if use examples; then
- emake sub-examples-all-ordered || die
- fi
-}
-
-src_install() {
- export SYSCONF=${D}${QTPREFIXDIR}/etc/settings
- export PATH="${S}/bin:${PATH}"
- export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
-
- make INSTALL_ROOT=${D} sub-tools-install_subtargets-ordered || die
-
- if use examples; then
- make INSTALL_ROOT=${D} sub-examples-install_subtargets || die
- fi
-
- make INSTALL_ROOT=${D} install_qmake || die
- make INSTALL_ROOT=${D} install_mkspecs || die
-
- if use doc; then
- make INSTALL_ROOT=${D} install_htmldocs || die
- fi
-
- # The QtAssistant header files aren't installed..not sure why
- cp -a ${S}/include/QtAssistant ${D}/${QTHEADERDIR}/QtAssistant
-
- # Fix symlink
- cd ${D}/${QTDATADIR}/mkspecs
- rm default
- ln -s $(qt_mkspecs_dir) default
- cd ${S}
-
- mkdir -p ${D}/${QTSYSCONFDIR}
-
- #sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.la
- #sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
- #sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/pkgconfig/*.pc
- #sed -i -e "s:${S}:${QTBASEDIR}:g" ${D}/${QTLIBDIR}/pkgconfig/*.pc
-
- # List all the multilib libdirs
- local libdirs
- for libdir in $(get_all_libdirs); do
- libdirs="${libdirs}:/usr/${libdir}/qt4"
- done
-
- mkdir -p ${D}/etc/env.d
-
- cat > ${D}/etc/env.d/44qt4 << EOF
-PATH=${QTBINDIR}
-ROOTPATH=${QTBINDIR}
-LDPATH=${libdirs:1}
-QMAKESPEC=$(qt_mkspecs_dir)
-EOF
-}