summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-02-06 22:30:37 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-02-06 22:30:37 +0000
commit448286807092024a6c5aaaec6398f711aa3775f6 (patch)
tree75b4fa34a07c87cef1201400caa04efc08914c70 /x11-libs
parentVersion bump. Clean up old revisions. (diff)
downloadgentoo-2-448286807092024a6c5aaaec6398f711aa3775f6.tar.gz
gentoo-2-448286807092024a6c5aaaec6398f711aa3775f6.tar.bz2
gentoo-2-448286807092024a6c5aaaec6398f711aa3775f6.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/ChangeLog8
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.30.4.ebuild100
2 files changed, 107 insertions, 1 deletions
diff --git a/x11-libs/gdk-pixbuf/ChangeLog b/x11-libs/gdk-pixbuf/ChangeLog
index 034afbfb406d..fd841f934ff4 100644
--- a/x11-libs/gdk-pixbuf/ChangeLog
+++ b/x11-libs/gdk-pixbuf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gdk-pixbuf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.96 2014/01/04 20:46:23 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.97 2014/02/06 22:30:37 eva Exp $
+
+*gdk-pixbuf-2.30.4 (06 Feb 2014)
+
+ 06 Feb 2014; Gilles Dartiguelongue <eva@gentoo.org>
+ +gdk-pixbuf-2.30.4.ebuild:
+ Version bump.
04 Jan 2014; Steev Klimaszewski <steev@gentoo.org> gdk-pixbuf-2.26.5.ebuild:
Parallel install fails when no gdk-pixbuf is already installed, bug #481372
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.30.4.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.30.4.ebuild
new file mode 100644
index 000000000000..04e826d64048
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.30.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/gdk-pixbuf-2.30.4.ebuild,v 1.1 2014/02/06 22:30:37 eva Exp $
+
+EAPI="5"
+
+inherit gnome.org gnome2-utils multilib libtool
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+X debug +introspection jpeg jpeg2k tiff test"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.6:2
+ >=media-libs/libpng-1.4:0=
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg:0= )
+ jpeg2k? ( media-libs/jasper:= )
+ tiff? ( >=media-libs/tiff-3.9.2:0= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ !<gnome-base/librsvg-2.31.0
+ !<x11-libs/gtk+-2.21.3:2
+ !<x11-libs/gtk+-2.90.4:3
+"
+
+src_prepare() {
+ # This will avoid polluting the pkg-config file with versioned libpng,
+ # which is causing problems with libpng14 -> libpng15 upgrade
+ # See upstream bug #667068
+ # First check that the pattern is present, to catch upstream changes on bumps,
+ # because sed doesn't return failure code if it doesn't do any replacements
+ grep -q 'l in libpng16' configure || die "libpng check order has changed upstream"
+ sed -e 's:l in libpng16:l in libpng libpng16:' -i configure || die
+ default
+ elibtoolize # for Darwin modules, bug #???
+}
+
+src_configure() {
+ # png always on to display icons
+ econf \
+ $(usex debug --enable-debug=yes "") \
+ $(use_with jpeg libjpeg) \
+ $(use_with jpeg2k libjasper) \
+ $(use_with tiff libtiff) \
+ $(use_enable introspection) \
+ $(use_with X x11) \
+ --with-libpng
+}
+
+src_install() {
+ # Parallel install fails when no gdk-pixbuf is already installed, bug #481372
+ MAKEOPTS+=" -j1" default
+ prune_libtool_files --modules
+}
+
+pkg_preinst() {
+ gnome2_gdk_pixbuf_savelist
+
+ # Make sure loaders.cache belongs to gdk-pixbuf alone
+ local cache="usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ gnome2_gdk_pixbuf_update
+
+ # Migration snippet for when this was handled by gtk+
+ if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
+ fi
+}
+
+pkg_postrm() {
+ if [[ -z ${REPLACED_BY_VERSIONS} ]]; then
+ rm -f "${EROOT}"usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache
+ fi
+}