summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-12-21 23:28:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-12-21 23:28:30 +0000
commit4b986b1a2e7ef2a6de8df636dc1bb3ee7d0b1e52 (patch)
tree14066f9a5b7d5d231d275a98a08e861ad6c55821 /x11-libs
parentVersion bump. Bug fixes. (diff)
downloadgentoo-2-4b986b1a2e7ef2a6de8df636dc1bb3ee7d0b1e52.tar.gz
gentoo-2-4b986b1a2e7ef2a6de8df636dc1bb3ee7d0b1e52.tar.bz2
gentoo-2-4b986b1a2e7ef2a6de8df636dc1bb3ee7d0b1e52.zip
Version bump. Bug fixes.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/pango-1.26.2.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index cbd3dcbe0cd9..a719aa1d4cab 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.279 2009/11/28 17:39:38 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.280 2009/12/21 23:28:30 eva Exp $
+
+*pango-1.26.2 (21 Dec 2009)
+
+ 21 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org> +pango-1.26.2.ebuild:
+ Version bump. Bug fixes.
28 Nov 2009; Rémi Cardona <remi@gentoo.org> pango-1.24.5-r1.ebuild,
pango-1.26.0.ebuild:
diff --git a/x11-libs/pango/pango-1.26.2.ebuild b/x11-libs/pango/pango-1.26.2.ebuild
new file mode 100644
index 000000000000..1ef825241e86
--- /dev/null
+++ b/x11-libs/pango/pango-1.26.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.26.2.ebuild,v 1.1 2009/12/21 23:28:30 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 multilib
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X doc test"
+
+RDEPEND=">=dev-libs/glib-2.17.3
+ >=media-libs/fontconfig-2.5.0
+ media-libs/freetype:2
+ >=x11-libs/cairo-1.7.6[X?]
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ dev-util/gtk-doc-am
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ test? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ X? ( x11-proto/xproto )"
+
+DOCS="AUTHORS ChangeLog* NEWS README THANKS"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" = "lib32" ] )
+}
+
+pkg_setup() {
+ # XXX: DO NOT add introspection support, collides with gir-repository[pango]
+ G2CONF="${G2CONF}
+ --disable-introspection
+ $(use_with X x)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.26.0-lib64.patch"
+ fi
+
+ # gtk-doc checks do not pass, upstream bug #578944
+ sed -e 's:TESTS = check.docs: TESTS = :g' \
+ -i docs/Makefile.am || die "sed failed"
+
+ # Fix introspection automagic.
+ # https://bugzilla.gnome.org/show_bug.cgi?id=596506
+ epatch "${FILESDIR}/${PN}-1.26.0-introspection-automagic.patch"
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}