summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-18 04:01:27 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-18 04:01:27 +0000
commit4c8139c23086ba75b49327fccba5826c68a91c40 (patch)
tree4782212a956b683d09aa6ad933d192e2f71ea922 /x11-libs
parentVersion bump. Respect LDFLAGS (bug #335961), more CFLAGS. (diff)
downloadgentoo-2-4c8139c23086ba75b49327fccba5826c68a91c40.tar.gz
gentoo-2-4c8139c23086ba75b49327fccba5826c68a91c40.tar.bz2
gentoo-2-4c8139c23086ba75b49327fccba5826c68a91c40.zip
Respect LDFLAGS (bug #335968), CC by deploying autotools. Fix some compiler warnings. Use emake instead of make. Use econf instead of ./configure.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libPropList/ChangeLog13
-rw-r--r--x11-libs/libPropList/files/libPropList-0.10.1-include.patch10
-rw-r--r--x11-libs/libPropList/libPropList-0.10.1-r2.ebuild24
-rw-r--r--x11-libs/libPropList/libPropList-0.10.1-r4.ebuild29
4 files changed, 50 insertions, 26 deletions
diff --git a/x11-libs/libPropList/ChangeLog b/x11-libs/libPropList/ChangeLog
index c83bb7cda416..b6c721009725 100644
--- a/x11-libs/libPropList/ChangeLog
+++ b/x11-libs/libPropList/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/libPropList
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libPropList/ChangeLog,v 1.13 2008/04/21 18:27:02 phreak Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libPropList/ChangeLog,v 1.14 2010/09/18 04:01:27 jer Exp $
+
+*libPropList-0.10.1-r4 (18 Sep 2010)
+
+ 18 Sep 2010; Jeroen Roovers <jer@gentoo.org>
+ -libPropList-0.10.1-r2.ebuild, +libPropList-0.10.1-r4.ebuild,
+ +files/libPropList-0.10.1-include.patch:
+ Respect LDFLAGS (bug #335968), CC by deploying autotools. Fix some
+ compiler warnings. Use emake instead of make. Use econf instead of
+ ./configure.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/x11-libs/libPropList/files/libPropList-0.10.1-include.patch b/x11-libs/libPropList/files/libPropList-0.10.1-include.patch
new file mode 100644
index 000000000000..c9c75cce86d2
--- /dev/null
+++ b/x11-libs/libPropList/files/libPropList-0.10.1-include.patch
@@ -0,0 +1,10 @@
+--- comparing.c.orig 1999-01-28 08:11:03.000000000 +0100
++++ comparing.c 2010-09-18 05:52:24.000000000 +0200
+@@ -4,6 +4,7 @@
+
+ */
+
++#include <string.h> /* strcmp(), memcmp() */
+ #include "proplistP.h"
+
+ /* forward prototype */
diff --git a/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild b/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild
deleted file mode 100644
index b0892360615f..000000000000
--- a/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libPropList/libPropList-0.10.1-r2.ebuild,v 1.15 2009/05/05 08:02:11 ssuominen Exp $
-
-DESCRIPTION="libPropList"
-SRC_URI="ftp://ftp.windowmaker.org/pub/release/srcs/current/${P}.tar.gz"
-HOMEPAGE="http://www.windowmaker.org/"
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc "
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-src_compile() {
- ./configure --host=${CHOST} --prefix=/usr || die
- make || die
-}
-
-src_install() {
- make prefix="${D}/usr" install || die
- dodoc AUTHORS ChangeLog README TODO
-}
diff --git a/x11-libs/libPropList/libPropList-0.10.1-r4.ebuild b/x11-libs/libPropList/libPropList-0.10.1-r4.ebuild
new file mode 100644
index 000000000000..29ddce10f492
--- /dev/null
+++ b/x11-libs/libPropList/libPropList-0.10.1-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libPropList/libPropList-0.10.1-r4.ebuild,v 1.1 2010/09/18 04:01:27 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="libPropList"
+HOMEPAGE="http://www.windowmaker.org/"
+SRC_URI="ftp://ftp.windowmaker.org/pub/libs/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake prefix="${D}/usr" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}