summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 21:43:48 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 21:43:48 +0000
commit4eaa77d739319d41172d8ebe85930b0f44fe8333 (patch)
tree3d0daaee4209f27faa3f07ab85d1d2a54d781c54 /x11-libs
parentremoved older ebuilds (diff)
downloadgentoo-2-4eaa77d739319d41172d8ebe85930b0f44fe8333.tar.gz
gentoo-2-4eaa77d739319d41172d8ebe85930b0f44fe8333.tar.bz2
gentoo-2-4eaa77d739319d41172d8ebe85930b0f44fe8333.zip
cleanup
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/qt-3.0.3-r1.ebuild121
-rw-r--r--x11-libs/qt/qt-3.0.3.1.ebuild139
-rw-r--r--x11-libs/qt/qt-3.0.3.ebuild123
-rw-r--r--x11-libs/xforms/xforms-089.ebuild28
4 files changed, 204 insertions, 207 deletions
diff --git a/x11-libs/qt/qt-3.0.3-r1.ebuild b/x11-libs/qt/qt-3.0.3-r1.ebuild
index 17e502835bc2..1ad922c3c53d 100644
--- a/x11-libs/qt/qt-3.0.3-r1.ebuild
+++ b/x11-libs/qt/qt-3.0.3-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3-r1.ebuild,v 1.2 2002/04/17 05:04:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3-r1.ebuild,v 1.3 2002/04/27 21:40:20 seemant Exp $
-P=qt-x11-${PV}
S=${WORKDIR}/qt-x11-free-${PV}
DESCRIPTION="QT version ${PV}"
@@ -28,91 +27,91 @@ export QTDIR=${S}
src_unpack() {
- export QTDIR=${S}
+ export QTDIR=${S}
- unpack ${A}
+ unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
}
src_compile() {
- export QTDIR=${S}
-
- export LDFLAGS="-ldl"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif"
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
- use odbc && myconf="${myconf} -plugin-sql-odbc"
- [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
-
- # avoid wasting time building things we won't install
- rm -rf tutorial examples
+ export QTDIR=${S}
- ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
- -system-libmng -system-libpng -ldl -lpthread -xft || die
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -xft || die
- export QTDIR=${S}
+ export QTDIR=${S}
- emake src-qmake src-moc sub-src sub-tools || die
+ emake src-qmake src-moc sub-src sub-tools || die
}
src_install() {
- export QTDIR=${S}
+ export QTDIR=${S}
- cd ${S}
+ cd ${S}
- # binaries
- into $QTBASE
- dobin bin/*
+ # binaries
+ into $QTBASE
+ dobin bin/*
- # libraries
- dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
- cd ${D}$QTBASE/lib
- for x in libqui.so libeditor.so
- do
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
ln -s $x.1.0.0 $x.1.0
ln -s $x.1.0 $x.1
ln -s $x.1 $x
- done
- ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
- ln -s libqt-mt.so.3.0 libqt-mt.so.3
- ln -s libqt-mt.so.3 libqt-mt.so
-
- # includes
- cd ${S}
- dodir ${QTBASE}/include/private
- cp include/* ${D}/${QTBASE}/include/
- cp include/private/* ${D}/${QTBASE}/include/private/
-
- # misc
- insinto /etc/env.d
- doins ${FILESDIR}/{45qt3,50qtdir3}
-
- # misc build reqs
- dodir ${QTBASE}/mkspecs
- cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
-
- sed -e "s:${D}::g" \
- -e "s:qt-x11-free-3.0.1::g" \
+ done
+ ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
-e "s:${WORKDIR}:${QTBASE}:" \
-e "s:/usr/local/qt:${QTBASE}:" \
${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
- # plugins
- cd ${S}
- plugins=`find plugins -name "lib*.so" -print`
- for x in $plugins; do
- insinto ${QTBASE}/`dirname $x`
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
doins $x
- done
+ done
}
diff --git a/x11-libs/qt/qt-3.0.3.1.ebuild b/x11-libs/qt/qt-3.0.3.1.ebuild
index 69907c0ef4e7..6fea009b6d6a 100644
--- a/x11-libs/qt/qt-3.0.3.1.ebuild
+++ b/x11-libs/qt/qt-3.0.3.1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3.1.ebuild,v 1.1 2002/04/18 08:01:59 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3.1.ebuild,v 1.2 2002/04/27 21:40:20 seemant Exp $
# qt-copy-3.0.3 ebuild (released with kde3)
-P=qt-x11-${PV}
PV=3.0.3
S=${WORKDIR}/qt-x11-free-${PV}
@@ -37,99 +36,99 @@ export QTDIR=${S}
src_unpack() {
- export QTDIR=${S}
+ export QTDIR=${S}
- unpack ${A}
+ unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
}
src_compile() {
- export QTDIR=${S}
-
- export LDFLAGS="-ldl"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif"
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
- use odbc && myconf="${myconf} -plugin-sql-odbc"
- [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
-
- # avoid wasting time building things we won't install
- rm -rf tutorial examples
+ export QTDIR=${S}
- ./configure -sm -thread -stl -system-zlib -system-libjpeg -qt-imgfmt-{jpeg,mng,png} ${myconf} \
- -system-libmng -system-libpng -ldl -lpthread -xft || die
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -qt-imgfmt-{jpeg,mng,png} ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -xft || die
- export QTDIR=${S}
+ export QTDIR=${S}
- emake src-qmake src-moc sub-src sub-tools || die
+ emake src-qmake src-moc sub-src sub-tools || die
}
src_install() {
- export QTDIR=${S}
+ export QTDIR=${S}
- cd ${S}
+ cd ${S}
- # binaries
- into $QTBASE
- dobin bin/*
+ # binaries
+ into $QTBASE
+ dobin bin/*
- # libraries
- dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
- cd ${D}$QTBASE/lib
- for x in libqui.so libeditor.so
- do
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
ln -s $x.1.0.0 $x.1.0
ln -s $x.1.0 $x.1
ln -s $x.1 $x
- done
-
- # version symlinks - 3.0.3->3.0->3->.so
- ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
- ln -s libqt-mt.so.3.0 libqt-mt.so.3
- ln -s libqt-mt.so.3 libqt-mt.so
-
- # libqt -> libqt-mt symlinks
- ln -s libqt-mt.so.${PV} libqt.so.${PV}
- ln -s libqt-mt.so.3.0 libqt.so.3.0
- ln -s libqt-mt.so.3 libqt.so.3
- ln -s libqt-mt.so libqt.so
-
- # includes
- cd ${S}
- dodir ${QTBASE}/include/private
- cp include/* ${D}/${QTBASE}/include/
- cp include/private/* ${D}/${QTBASE}/include/private/
-
- # misc
- insinto /etc/env.d
- doins ${FILESDIR}/{45qt3,50qtdir3}
-
- # misc build reqs
- dodir ${QTBASE}/mkspecs
- cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
-
- sed -e "s:${D}::g" \
- -e "s:qt-x11-free-3.0.1::g" \
+ done
+
+ # version symlinks - 3.0.3->3.0->3->.so
+ ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.${PV} libqt.so.${PV}
+ ln -s libqt-mt.so.3.0 libqt.so.3.0
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
-e "s:${WORKDIR}:${QTBASE}:" \
-e "s:/usr/local/qt:${QTBASE}:" \
${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
- # plugins
- cd ${S}
- plugins=`find plugins -name "lib*.so" -print`
- for x in $plugins; do
- insinto ${QTBASE}/`dirname $x`
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
doins $x
- done
+ done
}
diff --git a/x11-libs/qt/qt-3.0.3.ebuild b/x11-libs/qt/qt-3.0.3.ebuild
index fe4e00e1e9f1..a800cdf67bff 100644
--- a/x11-libs/qt/qt-3.0.3.ebuild
+++ b/x11-libs/qt/qt-3.0.3.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3.ebuild,v 1.1 2002/03/26 10:52:55 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.3.ebuild,v 1.2 2002/04/27 21:40:20 seemant Exp $
-P=qt-x11-${PV}
S=${WORKDIR}/qt-x11-free-${PV}
DESCRIPTION="QT version ${PV}"
@@ -25,91 +24,91 @@ export QTDIR=${S}
src_unpack() {
- export QTDIR=${S}
+ export QTDIR=${S}
- unpack ${A}
+ unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
}
src_compile() {
- export QTDIR=${S}
-
- export LDFLAGS="-ldl"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif"
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
- use odbc && myconf="${myconf} -plugin-sql-odbc"
- [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
-
- # avoid wasting time building things we won't install
- rm -rf tutorial examples
+ export QTDIR=${S}
- ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
- -system-libmng -system-libpng -ldl -lpthread -xft || die
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql -I/usr/include/postgresql/libpq -L/usr/lib"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread -xft || die
- export QTDIR=${S}
+ export QTDIR=${S}
- emake src-qmake src-moc sub-src sub-tools || die
+ emake src-qmake src-moc sub-src sub-tools || die
}
src_install() {
- export QTDIR=${S}
+ export QTDIR=${S}
- cd ${S}
+ cd ${S}
- # binaries
- into $QTBASE
- dobin bin/*
+ # binaries
+ into $QTBASE
+ dobin bin/*
- # libraries
- dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
- cd ${D}$QTBASE/lib
- for x in libqui.so libeditor.so
- do
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
ln -s $x.1.0.0 $x.1.0
ln -s $x.1.0 $x.1
ln -s $x.1 $x
- done
- ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
- ln -s libqt-mt.so.3.0 libqt-mt.so.3
- ln -s libqt-mt.so.3 libqt-mt.so
-
- # includes
- cd ${S}
- dodir ${QTBASE}/include/private
- cp include/* ${D}/${QTBASE}/include/
- cp include/private/* ${D}/${QTBASE}/include/private/
-
- # misc
- insinto /etc/env.d
- doins ${FILESDIR}/{45qt3,50qtdir3}
-
- # misc build reqs
- dodir ${QTBASE}/mkspecs
- cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
-
- sed -e "s:${D}::g" \
- -e "s:qt-x11-free-3.0.1::g" \
+ done
+ ln -s libqt-mt.so.${PV} libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
-e "s:${WORKDIR}:${QTBASE}:" \
-e "s:/usr/local/qt:${QTBASE}:" \
${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
- # plugins
- cd ${S}
- plugins=`find plugins -name "lib*.so" -print`
- for x in $plugins; do
- insinto ${QTBASE}/`dirname $x`
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
doins $x
- done
+ done
}
diff --git a/x11-libs/xforms/xforms-089.ebuild b/x11-libs/xforms/xforms-089.ebuild
index 9159e8312514..11b0f9e5fb8f 100644
--- a/x11-libs/xforms/xforms-089.ebuild
+++ b/x11-libs/xforms/xforms-089.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-089.ebuild,v 1.2 2001/06/08 22:43:03 achim Exp $
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-089.ebuild,v 1.3 2002/04/27 21:43:48 seemant Exp $
-#P=
-A=bxform-${PV}-glibc2.1.tgz
+MY_P=bxform-${PV}-glibc2.1
S=${WORKDIR}/${PN}
DESCRIPTION="A GUI Toolkit based on Xlib"
-SRC_URI="ftp://ncmir.ucsd.edu/pub/xforms/linux-i386/elf/${A}"
+SRC_URI="ftp://ncmir.ucsd.edu/pub/xforms/linux-i386/elf/${MY_P}.tgz"
HOMEPAGE="http://world.std.com/~xforms/"
DEPEND="virtual/x11"
-src_compile () {
- try make
+src_compile() {
+ make || die
}
+
src_install () {
- into /usr/X11R6
- dolib FORMS/libforms.{a,so.*}
- dosym /usr/X11R6/lib/libforms.so.0.89 /usr/X11R6/lib/libforms.so
- insinto /usr/X11R6/include
- doins FORMS/forms.h
- doman FORMS/xforms.5
+ into /usr/X11R6
+ dolib FORMS/libforms.{a,so.*}
+ dosym /usr/X11R6/lib/libforms.so.0.89 /usr/X11R6/lib/libforms.so
+ insinto /usr/X11R6/include
+ doins FORMS/forms.h
+ doman FORMS/xforms.5
}