summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-25 18:21:06 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-25 18:21:06 +0000
commit5ccc024adf0026c98cc41a7c323f522a62dbd9d7 (patch)
treed91e82675ea79fb6af33db96ccc5f43331c0cf3a /x11-libs
parentFix LICENSE, wrt bug #463346 (diff)
downloadgentoo-2-5ccc024adf0026c98cc41a7c323f522a62dbd9d7.tar.gz
gentoo-2-5ccc024adf0026c98cc41a7c323f522a62dbd9d7.tar.bz2
gentoo-2-5ccc024adf0026c98cc41a7c323f522a62dbd9d7.zip
Version bump, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/vte-0.34.4.ebuild (renamed from x11-libs/vte/vte-0.32.2.ebuild)53
2 files changed, 34 insertions, 27 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 5b40fc928e5f..6f77fac86131 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.363 2013/04/10 20:22:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.364 2013/04/25 18:21:06 pacho Exp $
+
+*vte-0.34.4 (25 Apr 2013)
+
+ 25 Apr 2013; Pacho Ramos <pacho@gentoo.org> +vte-0.34.4.ebuild,
+ -vte-0.32.2.ebuild:
+ Version bump, drop old
10 Apr 2013; Agostino Sarubbo <ago@gentoo.org> vte-0.34.2.ebuild:
Stable for hppa, wrt bug #458984
diff --git a/x11-libs/vte/vte-0.32.2.ebuild b/x11-libs/vte/vte-0.34.4.ebuild
index 353ef0d8f7d2..235f974c18d2 100644
--- a/x11-libs/vte/vte-0.32.2.ebuild
+++ b/x11-libs/vte/vte-0.34.4.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.32.2.ebuild,v 1.10 2012/10/28 16:37:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.34.4.ebuild,v 1.1 2013/04/25 18:21:06 pacho Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
inherit eutils gnome2
-DESCRIPTION="GNOME terminal widget"
-HOMEPAGE="https://live.gnome.org/VTE"
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://live.gnome.org/Terminal/VTE"
LICENSE="LGPL-2+"
SLOT="2.90"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE="debug doc glade +introspection"
+IUSE="debug glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
-PDEPEND="x11-libs/gnome-pty-helper"
-RDEPEND=">=dev-libs/glib-2.31.13:2
+PDEPEND="=x11-libs/gnome-pty-helper-${PV}"
+RDEPEND="
+ >=dev-libs/glib-2.31.13:2
>=x11-libs/gtk+-3.1.9:3[introspection?]
>=x11-libs/pango-1.22.0
@@ -26,24 +26,15 @@ RDEPEND=">=dev-libs/glib-2.31.13:2
x11-libs/libXft
glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
- virtual/pkgconfig
sys-devel/gettext
- doc? ( >=dev-util/gtk-doc-1.13 )"
-
-pkg_setup() {
- # Python bindings are via gobject-introspection
- # Ex: from gi.repository import Vte
- # Do not disable gnome-pty-helper, bug #401389
- G2CONF="${G2CONF}
- --disable-deprecation
- --disable-static
- $(use_enable debug)
- $(use_enable glade glade-catalogue)
- $(use_enable introspection)"
+ virtual/pkgconfig
+"
+src_prepare() {
if [[ ${CHOST} == *-interix* ]]; then
G2CONF="${G2CONF} --disable-Bsymbolic"
@@ -52,15 +43,25 @@ pkg_setup() {
fi
DOCS="AUTHORS ChangeLog HACKING NEWS README"
-}
-src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=663779
epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
gnome2_src_prepare
}
+src_configure() {
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ # Do not disable gnome-pty-helper, bug #401389
+ gnome2_src_configure \
+ --disable-deprecation \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_enable introspection)
+}
+
src_install() {
gnome2_src_install
rm -v "${ED}usr/libexec/gnome-pty-helper" || die