summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-31 14:34:32 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-31 14:34:32 +0000
commit5f09cef6fb7ecc757f0d53312f30990a80cabc81 (patch)
tree6879eddb18dc42e808d54836cf3be9f748562a95 /x11-libs
parentnew release (Manifest recommit) (diff)
downloadgentoo-2-5f09cef6fb7ecc757f0d53312f30990a80cabc81.tar.gz
gentoo-2-5f09cef6fb7ecc757f0d53312f30990a80cabc81.tar.bz2
gentoo-2-5f09cef6fb7ecc757f0d53312f30990a80cabc81.zip
added a much much simpler and much less invasive fix for gcc 3.4
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch12
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r5.ebuild8
3 files changed, 10 insertions, 16 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index a9b1bfb7a8f7..f7b7f17eb8b6 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.44 2004/05/29 20:03:53 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.45 2004/05/31 14:34:32 lv Exp $
+
+ 31 May 2004; Travis Tilley <lv@gentoo.org>
+ -files/openmotif-2.1.30-gcc34.patch, openmotif-2.1.30-r5.ebuild:
+ added a much much simpler and much less invasive fix for gcc 3.4
29 May 2004; Travis Tilley <lv@gentoo.org>
+files/openmotif-2.1.30-gcc34.patch, openmotif-2.1.30-r5.ebuild:
diff --git a/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch b/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch
deleted file mode 100644
index d7d56295e103..000000000000
--- a/x11-libs/openmotif/files/openmotif-2.1.30-gcc34.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- motif.old/lib/Xm/Scale.c 2004-05-29 15:39:27.089621032 +0000
-+++ motif/lib/Xm/Scale.c 2004-05-29 15:44:09.597673280 +0000
-@@ -81,6 +81,9 @@
- #ifdef __cplusplus
- extern "C" { /* some 'locale.h' do not have prototypes (sun) */
- #endif
-+#ifdef X_LOCALE
-+#undef X_LOCALE
-+#endif
- #include <X11/Xlocale.h>
- #ifdef __cplusplus
- } /* Close scope of 'extern "C"' declaration */
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
index 2930b2692a1a..a8b33ed39085 100644
--- a/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
+++ b/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.4 2004/05/29 20:03:53 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r5.ebuild,v 1.5 2004/05/31 14:34:32 lv Exp $
inherit eutils
@@ -40,7 +40,10 @@ src_unpack() {
echo >>$cfg "#undef OptimizedCDebugFlags" && \
echo >>$cfg "#define OptimizedCDebugFlags ${CFLAGS}" && \
echo >>$cfg "#undef OptimizedCplusplusDebugFlags" && \
- echo >>$cfg "#define OptimizedCplusplusDebugFlags ${CXXFLAGS}"
+ echo >>$cfg "#define OptimizedCplusplusDebugFlags ${CXXFLAGS}" &&\
+ echo >>$cfg "#undef LinuxCLibMajorVersion" && \
+ echo >>$cfg "#define LinuxCLibMajorVersion 6"
+
eend $? || die
sed -i -e "s:#define USE_BYACC YES:#undef USE_BYACC:" config/cf/host.def
@@ -59,7 +62,6 @@ src_unpack() {
# compile on gcc 2.9x
epatch ${FILESDIR}/${P}-imake-ansi.patch
epatch ${FILESDIR}/${P}-uil-bad_grammar_fix.diff
- epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {