summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-11 12:51:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-11 12:51:00 +0000
commit732a7e25b240643a86addc20d2c96cf7736a2962 (patch)
tree35bbfc9b6ef32d12651a179ffa97cdda6cfa33dc /x11-libs
parentversion bump (diff)
downloadgentoo-2-732a7e25b240643a86addc20d2c96cf7736a2962.tar.gz
gentoo-2-732a7e25b240643a86addc20d2c96cf7736a2962.tar.bz2
gentoo-2-732a7e25b240643a86addc20d2c96cf7736a2962.zip
version bump
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vdpau-video/ChangeLog7
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-libs/vdpau-video/ChangeLog b/x11-libs/vdpau-video/ChangeLog
index 05e936676723..68f86b4ca0c3 100644
--- a/x11-libs/vdpau-video/ChangeLog
+++ b/x11-libs/vdpau-video/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vdpau-video
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.16 2012/05/05 03:52:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/ChangeLog,v 1.17 2012/10/11 12:51:00 aballier Exp $
+
+*vdpau-video-0.7.4 (11 Oct 2012)
+
+ 11 Oct 2012; Alexis Ballier <aballier@gentoo.org> +vdpau-video-0.7.4.ebuild:
+ version bump
05 May 2012; Jeff Horelick <jdhore@gentoo.org> vdpau-video-0.7.3.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild b/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild
new file mode 100644
index 000000000000..2800a1bd2017
--- /dev/null
+++ b/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.7.4.ebuild,v 1.1 2012/10/11 12:51:00 aballier Exp $
+
+EAPI="2"
+inherit autotools
+
+MY_P=libva-vdpau-driver-${PV}
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.freedesktop.org/software/vaapi/releases/libva-vdpau-driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/libva-1.1.0[X,opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}