summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-08-04 07:43:02 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-08-04 07:43:02 +0000
commit8106ef3d7ecd54f1a9e40132a3ba6b929862eca4 (patch)
treebefe4909b4979d65ec422661ef52c0c222cb8bfe /x11-libs
parentnew versions without debugging and with changed build processs. masked (diff)
downloadgentoo-2-8106ef3d7ecd54f1a9e40132a3ba6b929862eca4.tar.gz
gentoo-2-8106ef3d7ecd54f1a9e40132a3ba6b929862eca4.tar.bz2
gentoo-2-8106ef3d7ecd54f1a9e40132a3ba6b929862eca4.zip
new version, revised build procvess, removes teh sue flags from SRC_URI.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.6-r11
-rw-r--r--x11-libs/gtk+/gtk+-2.0.6-r1.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 9631bc5c2b4b..2bf49b3472b5 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.21 2002/08/03 22:58:35 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.22 2002/08/04 07:43:02 spider Exp $
+
+
+*gtk+-2.0.6-r1 (04 Jul 2002)
+ 04 Jul 2002; Spider <spider@gentoo.org> gtk+-2.0.6-r1.ebuild :
+ remove unnecessary debugging
+ remove bad parts from SRC_URI (broken use)
+ changed configure some
*gtk+-2.0.6 (04 Jul 2002)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.6-r1 b/x11-libs/gtk+/files/digest-gtk+-2.0.6-r1
new file mode 100644
index 000000000000..257c87d6a275
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.6-r1
@@ -0,0 +1 @@
+MD5 5f9c1b54abea95408155045c661a5adf gtk+-2.0.6.tar.bz2 6118141
diff --git a/x11-libs/gtk+/gtk+-2.0.6-r1.ebuild b/x11-libs/gtk+/gtk+-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..59f9c965e512
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.6-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.6-r1.ebuild,v 1.1 2002/08/04 07:43:02 spider Exp $
+
+inherit libtool
+
+SLOT="2"
+KEYWORDS="x86 ppc"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+# mirror://gentoo//${PN}-directfb-${PV}-gentoo.patch.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.6-r1
+ >=dev-libs/atk-1.0.3-r1
+ >=x11-libs/pango-1.0.4-r1
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ directfb? ( dev-libs/DirectFB )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_unpack() {
+
+ unpack ${P}.tar.bz2
+ cd ${S}
+# use directfb && ( \
+# ( bzcat ${DISTDIR}/${PN}-directfb-${PV}-gentoo.patch.bz2 \
+# | patch -p1 ) || die
+# )
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+
+ econf --with-gdktarget=x11 ${myconf} || die
+
+# gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+