summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-05-10 20:09:22 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-05-10 20:09:22 +0000
commit84fb91cde86c0cb6da60094f1845c5e66a3af2d9 (patch)
treeda0725e36aead8fbcdb1db805e8f91dce61df15f /x11-libs
parentVersion bump Qt 4.7.3 (diff)
downloadgentoo-2-84fb91cde86c0cb6da60094f1845c5e66a3af2d9.tar.gz
gentoo-2-84fb91cde86c0cb6da60094f1845c5e66a3af2d9.tar.bz2
gentoo-2-84fb91cde86c0cb6da60094f1845c5e66a3af2d9.zip
Version bump Qt 4.7.3
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog8
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 823aa4a63d7a..6f9895d95578 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.119 2011/05/09 22:11:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.120 2011/05/10 20:09:22 tampakrap Exp $
+
+*qt-webkit-4.7.3 (10 May 2011)
+
+ 10 May 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-webkit-4.7.3.ebuild:
+ Version bump Qt 4.7.3
09 May 2011; Markos Chandras <hwoarang@gentoo.org> qt-webkit-4.7.2.ebuild:
Stable on amd64 wrt bug #354033
diff --git a/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild b/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild
new file mode 100644
index 000000000000..840e62bfbdd6
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.7.3.ebuild,v 1.1 2011/05/10 20:09:22 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="dbus +jit kde"
+
+DEPEND="
+ dev-db/sqlite:3
+ ~x11-libs/qt-core-${PV}[aqua=,debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[aqua=,dbus?,debug=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=,debug=]
+ dbus? ( ~x11-libs/qt-dbus-${PV}[aqua=,debug=] )
+ !kde? ( || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug=]
+ media-libs/phonon[aqua=] ) )
+ kde? ( || ( media-libs/phonon[aqua=] ~x11-libs/qt-phonon-${PV}:${SLOT}[aqua=,dbus=,debug] ) )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/JavaScriptCore
+ src/3rdparty/webkit/WebCore
+ tools/designer/src/plugins/qwebview"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ QCONFIG_ADD="webkit"
+ QCONFIG_DEFINE="QT_WEBKIT"
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit -system-sqlite $(qt_use jit javascript-jit) $(qt_use dbus qdbus)"
+ qt4-build_src_configure
+}