summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Hrušecký <miska@gentoo.org>2012-07-30 18:14:13 +0000
committerMichal Hrušecký <miska@gentoo.org>2012-07-30 18:14:13 +0000
commit8983d7337dfdd7af16c2bf199b082b75c81d6bf7 (patch)
treee05626aae5c657440469d8fa0e62ae2a06300c89 /x11-libs
parentMake sure $PKG_CONFIG is respected. (diff)
downloadgentoo-2-8983d7337dfdd7af16c2bf199b082b75c81d6bf7.tar.gz
gentoo-2-8983d7337dfdd7af16c2bf199b082b75c81d6bf7.tar.bz2
gentoo-2-8983d7337dfdd7af16c2bf199b082b75c81d6bf7.zip
Fixed build with gcc-4.7 (bug#422065)
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libyui/ChangeLog8
-rw-r--r--x11-libs/libyui/files/libyui-2.21.1-gcc-47.patch12
-rw-r--r--x11-libs/libyui/libyui-2.21.1.ebuild7
3 files changed, 22 insertions, 5 deletions
diff --git a/x11-libs/libyui/ChangeLog b/x11-libs/libyui/ChangeLog
index 1e2161c6854c..f6b03972c8cd 100644
--- a/x11-libs/libyui/ChangeLog
+++ b/x11-libs/libyui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libyui
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui/ChangeLog,v 1.2 2011/08/15 17:08:20 miska Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui/ChangeLog,v 1.3 2012/07/30 18:14:12 miska Exp $
+
+ 30 Jul 2012; Michal Hrusecky <miska@gentoo.org> libyui-2.21.1.ebuild,
+ +files/libyui-2.21.1-gcc-47.patch:
+ Fixed build with gcc-4.7 (bug#422065)
15 Aug 2011; Michal Hrusecky <miska@gentoo.org> libyui-2.21.1.ebuild:
Disabling ~x86 for now, enabled by accident
diff --git a/x11-libs/libyui/files/libyui-2.21.1-gcc-47.patch b/x11-libs/libyui/files/libyui-2.21.1-gcc-47.patch
new file mode 100644
index 000000000000..66fad127ddd9
--- /dev/null
+++ b/x11-libs/libyui/files/libyui-2.21.1-gcc-47.patch
@@ -0,0 +1,12 @@
+diff -Naru libyui-2.21.1-orig/src/TreeItem.h libyui-2.21.1/src/TreeItem.h
+--- libyui-2.21.1-orig/src/TreeItem.h 2012-07-30 14:22:00.833938743 +0200
++++ libyui-2.21.1/src/TreeItem.h 2012-07-30 14:22:59.310288616 +0200
+@@ -251,7 +251,7 @@
+ // Insert as first child
+
+ newChild->setNext( firstChild() );
+- setFirstChild( newChild );
++ this->setFirstChild( newChild );
+ }
+ else
+ {
diff --git a/x11-libs/libyui/libyui-2.21.1.ebuild b/x11-libs/libyui/libyui-2.21.1.ebuild
index c1560563c8ae..095ee1927131 100644
--- a/x11-libs/libyui/libyui-2.21.1.ebuild
+++ b/x11-libs/libyui/libyui-2.21.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui/libyui-2.21.1.ebuild,v 1.2 2011/08/15 17:08:20 miska Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libyui/libyui-2.21.1.ebuild,v 1.3 2012/07/30 18:14:12 miska Exp $
EAPI=4
-inherit autotools
+inherit autotools eutils
DESCRIPTION="UI abstraction library"
HOMEPAGE="http://sourceforge.net/projects/libyui/"
@@ -24,6 +24,7 @@ PDEPEND="
"
src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc-47.patch"
eautoreconf
}