summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-02-09 02:16:39 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-02-09 02:16:39 +0000
commitaf9f64f6f78d46db866c7db56e3867250388d9f5 (patch)
tree13f021ec1431dd667a3d635981b2d5945de9360e /x11-libs
parentit fixes expat, though 81260 is not fixed as it is complete other issue (got ... (diff)
downloadgentoo-2-af9f64f6f78d46db866c7db56e3867250388d9f5.tar.gz
gentoo-2-af9f64f6f78d46db866c7db56e3867250388d9f5.tar.bz2
gentoo-2-af9f64f6f78d46db866c7db56e3867250388d9f5.zip
Patched to work with Automake-1.6 on ppc-macos. Stable ppc-macos
(Portage version: 2.0.51-r15)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog6
-rw-r--r--x11-libs/openmotif/files/openmotif-2.2.3-automake.patch10
-rw-r--r--x11-libs/openmotif/openmotif-2.2.3.ebuild23
3 files changed, 33 insertions, 6 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index a5842ca11a4b..c07a4a871682 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.71 2005/02/06 11:37:20 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.72 2005/02/09 02:16:39 j4rg0n Exp $
+
+ 08 Feb 2005; Lina Pezzella <j4rg0n@gentoo.org>
+ +files/openmotif-2.2.3-automake.patch, openmotif-2.2.3.ebuild:
+ Modified to work with Automake-1.6 on ppc-macos
06 Feb 2005; Heinrich Wendel <lanius@gentoo.org> openmotif-2.2.3.ebuild:
fix autotools dependencies
diff --git a/x11-libs/openmotif/files/openmotif-2.2.3-automake.patch b/x11-libs/openmotif/files/openmotif-2.2.3-automake.patch
new file mode 100644
index 000000000000..ed8fc14a805e
--- /dev/null
+++ b/x11-libs/openmotif/files/openmotif-2.2.3-automake.patch
@@ -0,0 +1,10 @@
+--- clients/uil/Makefile.am Fri Aug 15 04:56:19 2003
++++ clients/uil/Makefile.am.new Tue Feb 8 12:06:15 2005
+@@ -65,6 +65,7 @@
+ lib_LTLIBRARIES = libUil.la
+
+ libUil_la_SOURCES = $(SRCS)
++libUil_la_CFLAGS = $(AM_CFLAGS)
+
+ libUil_la_DEPENDENCIES = UilDBDef.h UilParser.lo
+
diff --git a/x11-libs/openmotif/openmotif-2.2.3.ebuild b/x11-libs/openmotif/openmotif-2.2.3.ebuild
index f1e7f38452c4..b01da3cb1163 100644
--- a/x11-libs/openmotif/openmotif-2.2.3.ebuild
+++ b/x11-libs/openmotif/openmotif-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3.ebuild,v 1.10 2005/02/06 11:37:20 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3.ebuild,v 1.11 2005/02/09 02:16:39 j4rg0n Exp $
inherit eutils libtool flag-o-matic multilib
@@ -12,13 +12,13 @@ SRC_URI="ftp://ftp.motifzone.net/om${PV}/src/${MY_P}.tar.gz"
LICENSE="MOTIF"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~ppc-macos sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ppc-macos sparc x86"
IUSE=""
DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- =sys-devel/automake-1.4*
+ !ppc-macos? ( =sys-devel/automake-1.4* )
=sys-devel/autoconf-2.5*
!virtual/motif"
RDEPEND="virtual/libc
@@ -46,14 +46,22 @@ src_unpack() {
epatch ${FILESDIR}/${P}-XmResizeHashTable.patch
epatch ${FILESDIR}/${P}-utf8.patch
epatch ${FILESDIR}/${P}-no_demos.patch
+ use ppc-macos && epatch ${FILESDIR}/${P}-automake.patch
# autotool stuff
export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.4
+
+ # Patched Makefile.am to work with version 1.6 on ppc-macos.
+ # Untested elsewhere
+ use ppc-macos || export WANT_AUTOMAKE=1.4
libtoolize --force --copy
aclocal || die
- automake --foreign || die
+ AUTOMAKE_OPTS="--foreign"
+ # For some reason ppc-macos complains about missing depcomp and compile
+ # files
+ use ppc-macos && AUTOMAKE_OPTS="-a -c -f ${AUTOMAKE_OPTS}"
+ automake ${AUTOMAKE_OPTS} || die
autoconf || die
}
@@ -95,6 +103,11 @@ src_install() {
# remove unneeded files
rm -fR ${D}/usr/$(get_libdir)/X11/bindings
+ # remove files provided by Apple's X11
+ if ( use ppc-macos && hasq collision-protect ${FEATURES} ); then
+ rm -fR ${D}/usr/include/X11/bitmaps/
+ fi
+
# install docs
dodoc COPYRIGHT.MOTIF LICENSE
dodoc README RELEASE RELNOTES