summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-11 13:04:25 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-11 13:04:25 +0000
commitc360fc3e07a4c0a4ea2807402a067a2c3fce07af (patch)
treeb8b00ab553315e42af18cadcecb7a66007473104 /x11-libs
parentVersion bump to 4.4.1 (diff)
downloadgentoo-2-c360fc3e07a4c0a4ea2807402a067a2c3fce07af.tar.gz
gentoo-2-c360fc3e07a4c0a4ea2807402a067a2c3fce07af.tar.bz2
gentoo-2-c360fc3e07a4c0a4ea2807402a067a2c3fce07af.zip
Version bump to 4.4.1
(Portage version: 2.2_rc7/cvs/Linux 2.6.26-hh1 i686, RepoMan options: --force)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-opengl/ChangeLog7
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.4.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index adfae99c1380..0f775d100c76 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.10 2008/06/13 23:22:22 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.11 2008/08/11 13:04:25 yngwin Exp $
+
+*qt-opengl-4.4.1 (11 Aug 2008)
+
+ 11 Aug 2008; Ben de Groot <yngwin@gentoo.org> +qt-opengl-4.4.1.ebuild:
+ Version bump
13 Jun 2008; Ingmar Vanhassel <ingmar@gentoo.org> qt-opengl-4.4.0.ebuild:
Make all split Qt4 ebuilds block the old monolithic ebuild.
diff --git a/x11-libs/qt-opengl/qt-opengl-4.4.1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.4.1.ebuild
new file mode 100644
index 000000000000..e8b8627f3083
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.4.1.ebuild,v 1.1 2008/08/11 13:04:25 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+qt3support"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/opengl"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+pkg_setup() {
+ use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support"
+ qt4-build_pkg_setup
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's commented out of the build in the source
+ qt4-build_src_compile
+}