summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-04 16:45:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-04 16:45:36 +0000
commitc59dfd5869771fd3b75c2324fb721f982849e115 (patch)
tree8d90eeb84721bb12a76c9d839c7ce4a1ad2d70d8 /x11-libs
parentVersion bumped. (diff)
downloadgentoo-2-c59dfd5869771fd3b75c2324fb721f982849e115.tar.gz
gentoo-2-c59dfd5869771fd3b75c2324fb721f982849e115.tar.bz2
gentoo-2-c59dfd5869771fd3b75c2324fb721f982849e115.zip
version bump. contains minor fixes for type1 and type3 font handling. Fixes API to conform to documentation.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog8
-rw-r--r--x11-libs/cairo/cairo-1.8.4.ebuild87
2 files changed, 94 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 028e5aa4f649..9cb53fcb045c 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.201 2008/10/31 20:45:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.202 2008/12/04 16:45:36 cardoe Exp $
+
+*cairo-1.8.4 (04 Dec 2008)
+
+ 04 Dec 2008; Doug Goldstein <cardoe@gentoo.org> +cairo-1.8.4.ebuild:
+ version bump. contains minor fixes for type1 and type3 font handling.
+ Fixes API to conform to documentation.
*cairo-1.8.2 (31 Oct 2008)
diff --git a/x11-libs/cairo/cairo-1.8.4.ebuild b/x11-libs/cairo/cairo-1.8.4.ebuild
new file mode 100644
index 000000000000..925029a28f66
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.8.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.8.4.ebuild,v 1.1 2008/12/04 16:45:36 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz opengl svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.9
+ sys-libs/zlib
+ media-libs/libpng
+ >=x11-libs/pixman-0.12.0
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )
+ X? ( >=x11-libs/libXrender-0.6
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft )
+ xcb? ( >=x11-libs/libxcb-0.92
+ x11-libs/xcb-util )"
+# test? (
+# pdf test
+# x11-libs/pango
+# >=x11-libs/gtk+-2.0
+# >=app-text/poppler-bindings-0.9.2
+# ps test
+# virtual/ghostscript
+# svg test
+# >=x11-libs/gtk+-2.0
+# >=gnome-base/librsvg-2.15.0
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1.6
+ ~app-text/docbook-xml-dtd-4.2 )
+ X? ( x11-proto/renderproto )
+ xcb? ( x11-proto/xcb-proto )"
+
+#pkg_setup() {
+# if ! built_with_use app-text/poppler-bindings gtk ; then
+# eerror 'poppler-bindings with gtk is required for the pdf backend'
+# die 'poppler-bindings built without gtk support'
+# fi
+#}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ if use glitz && use opengl; then
+ export glitz_LIBS=-lglitz-glx
+ fi
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) \
+ $(use_enable directfb) $(use_enable xcb) \
+ $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}