summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2011-05-22 14:43:15 +0000
committerAngelo Arrifano <miknix@gentoo.org>2011-05-22 14:43:15 +0000
commitd117a08c32ad05414e3b010a8c0595de0edcdc26 (patch)
tree24a6e3c75578f6c36d66c460daf6be58c405ec73 /x11-libs
parentMarked ~ppc for bug #365913. (diff)
downloadgentoo-2-d117a08c32ad05414e3b010a8c0595de0edcdc26.tar.gz
gentoo-2-d117a08c32ad05414e3b010a8c0595de0edcdc26.tar.bz2
gentoo-2-d117a08c32ad05414e3b010a8c0595de0edcdc26.zip
- Fix underlinking, bug #367595 .
- Patch configure.ac to work with latest autoconf (based on commit e13586b6b78d3636c3e00b437fdb4f3ac449b185 of cairo) - Move to EAPI 2. (Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libfakekey/ChangeLog13
-rw-r--r--x11-libs/libfakekey/files/libfakekey-0.1-ac.patch24
-rw-r--r--x11-libs/libfakekey/libfakekey-0.1-r1.ebuild (renamed from x11-libs/libfakekey/libfakekey-0.1.ebuild)23
3 files changed, 53 insertions, 7 deletions
diff --git a/x11-libs/libfakekey/ChangeLog b/x11-libs/libfakekey/ChangeLog
index 9d38210442bc..94220990ed9e 100644
--- a/x11-libs/libfakekey/ChangeLog
+++ b/x11-libs/libfakekey/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/libfakekey
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfakekey/ChangeLog,v 1.7 2009/12/14 04:58:28 yvasilev Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfakekey/ChangeLog,v 1.8 2011/05/22 14:43:15 miknix Exp $
+
+*libfakekey-0.1-r1 (22 May 2011)
+
+ 22 May 2011; Angelo Arrifano <miknix@gentoo.org> -libfakekey-0.1.ebuild,
+ +libfakekey-0.1-r1.ebuild, +files/libfakekey-0.1-ac.patch:
+ - Fix underlinking, bug #367595 .
+ - Patch configure.ac to work with latest autoconf (based on commit
+ e13586b6b78d3636c3e00b437fdb4f3ac449b185 of cairo git)
+ - Move to EAPI 2.
14 Dec 2009; Yuri Vasilevski <yvasilev@gentoo.org> libfakekey-0.1.ebuild:
Fixed dodoc QA notice, fixes bug #296757. Thanks flameeyes.
diff --git a/x11-libs/libfakekey/files/libfakekey-0.1-ac.patch b/x11-libs/libfakekey/files/libfakekey-0.1-ac.patch
new file mode 100644
index 000000000000..65c0b083aa72
--- /dev/null
+++ b/x11-libs/libfakekey/files/libfakekey-0.1-ac.patch
@@ -0,0 +1,24 @@
+--- configure.ac.old 2011-05-22 14:59:45.801746472 +0100
++++ configure.ac 2011-05-22 15:02:59.437159981 +0100
+@@ -14,16 +14,14 @@ AC_HEADER_STDC
+
+ dnl ------ libtool versioning -----------------------------------------------
+
+-LT_CURRENT=0
+-LT_REVISION=1
+-AC_SUBST(LT_CURRENT)
+-AC_SUBST(LT_REVISION)
+-LT_AGE=0
++m4_define(LT_CURRENT, 0)
++m4_define(LT_REVISION, 1)
++m4_define(LT_AGE, 0)
+
+-LT_VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
++LT_VERSION_INFO="LT_CURRENT():LT_REVISION():LT_AGE()"
+ AC_SUBST(LT_VERSION_INFO)
+
+-LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
++LT_CURRENT_MINUS_AGE="m4_eval(LT_CURRENT() - LT_AGE())"
+ AC_SUBST(LT_CURRENT_MINUS_AGE)
+
+ dnl ------ Check for X Stuff ------------------------------------------------
diff --git a/x11-libs/libfakekey/libfakekey-0.1.ebuild b/x11-libs/libfakekey/libfakekey-0.1-r1.ebuild
index 458869287626..4921baafa5c6 100644
--- a/x11-libs/libfakekey/libfakekey-0.1.ebuild
+++ b/x11-libs/libfakekey/libfakekey-0.1-r1.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfakekey/libfakekey-0.1.ebuild,v 1.8 2009/12/14 04:58:28 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfakekey/libfakekey-0.1-r1.ebuild,v 1.1 2011/05/22 14:43:15 miknix Exp $
+
+EAPI=2
+
+inherit eutils autotools
DESCRIPTION="Helper library for the x11-misc/matchbox-keyboard package."
HOMEPAGE="http://matchbox-project.org/"
@@ -16,14 +20,23 @@ RDEPEND="x11-libs/libXtst"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_compile() {
+src_prepare() {
+ # Allow configure to use libtool-2
+ epatch "${FILESDIR}/${P}-ac.patch"
+
+ # Fix underlinking bug #367595
+ sed -i -e 's/^fakekey_test_LDADD=/fakekey_test_LDADD=-lX11 /' \
+ tests/Makefile.am || die 'Cannot sed Makefile.am'
+
+ eautoreconf
+}
+
+src_configure() {
# --with/without-x is ignored by configure script and X is used.
econf --with-x \
$(use_enable debug) \
$(use_enable doc doxygen-docs) \
|| die "Configuration failed"
-
- emake || die "Compilation failed"
}
src_install() {