summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-22 23:29:22 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-22 23:29:22 +0000
commitd35a7b2cf9b69c5207aa0dd927e20609df8ccd68 (patch)
treefe0fdcd4bf8f102a59356ae09d8e8d724d6a1687 /x11-libs
parentVersion bump from the gnome overlay for gjs-1.32 compatibility (bug #413047, ... (diff)
downloadgentoo-2-d35a7b2cf9b69c5207aa0dd927e20609df8ccd68.tar.gz
gentoo-2-d35a7b2cf9b69c5207aa0dd927e20609df8ccd68.tar.bz2
gentoo-2-d35a7b2cf9b69c5207aa0dd927e20609df8ccd68.zip
Version bump with some bugfixes and updated python and php highlighting.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtksourceview/ChangeLog8
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.4.1.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 376bb2b183ad..443ad0538a6e 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.217 2012/04/19 20:46:39 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.218 2012/04/22 23:29:22 tetromino Exp $
+
+*gtksourceview-3.4.1 (22 Apr 2012)
+
+ 22 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gtksourceview-3.4.1.ebuild:
+ Version bump with some bugfixes and updated python and php highlighting.
19 Apr 2012; Brent Baude <ranger@gentoo.org> gtksourceview-2.10.5-r2.ebuild,
gtksourceview-3.2.3.ebuild:
diff --git a/x11-libs/gtksourceview/gtksourceview-3.4.1.ebuild b/x11-libs/gtksourceview/gtksourceview-3.4.1.ebuild
new file mode 100644
index 000000000000..0dc431533eb7
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.4.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.4.1.ebuild,v 1.1 2012/04/22 23:29:22 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="doc glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.28:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --enable-providers
+ $(use_enable glade glade-catalog)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ sed -i -e 's:--warn-all::' gtksourceview/Makefile.in || die
+
+ # Skip broken test until upstream bug #621383 is solved
+ sed -e "/guess-language/d" \
+ -e "/get-language/d" \
+ -i tests/test-languagemanager.c || die
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}