summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 00:16:01 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 00:16:01 +0000
commitd64d71976bcdb00a88a49c63ee3a4eff7b839838 (patch)
tree017b709d0b4f44a05cd744992733f1875e1edb3a /x11-libs
parentqt-4.4.2 version bump (diff)
downloadgentoo-2-d64d71976bcdb00a88a49c63ee3a4eff7b839838.tar.gz
gentoo-2-d64d71976bcdb00a88a49c63ee3a4eff7b839838.tar.bz2
gentoo-2-d64d71976bcdb00a88a49c63ee3a4eff7b839838.zip
qt-4.4.2 version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-sql/ChangeLog7
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 578cca541e2f..9a66a0ab037c 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.16 2008/08/16 03:29:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.17 2008/09/19 00:16:01 yngwin Exp $
+
+*qt-sql-4.4.2 (19 Sep 2008)
+
+ 19 Sep 2008; Ben de Groot <yngwin@gentoo.org> +qt-sql-4.4.2.ebuild:
+ Version bump
16 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/x11-libs/qt-sql/qt-sql-4.4.2.ebuild b/x11-libs/qt-sql/qt-sql-4.4.2.ebuild
new file mode 100644
index 000000000000..b1a45a7c0de8
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.4.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.2.ebuild,v 1.1 2008/09/19 00:16:01 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="firebird mysql odbc postgres +qt3support +sqlite"
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}
+ firebird? ( dev-db/firebird )
+ sqlite? ( dev-db/sqlite:3 )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )
+ odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}"
+
+pkg_setup() {
+ if ! (use firebird || use mysql || use odbc || use postgres || use sqlite); then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite\""
+ die "Enable at least one SQL driver."
+ fi
+
+ use qt3support && QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK}
+ ~x11-libs/qt-core-${PV} qt3support"
+
+ qt4-build_pkg_setup
+}
+
+src_unpack() {
+ qt4-build_src_unpack
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die 'Sed to fix postgresql usage in ./configure failed.'
+}
+
+src_compile() {
+ local myconf
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I/usr/include/mysql -L/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-svg"
+
+ qt4-build_src_compile
+}