summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-29 11:17:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-29 11:17:45 +0000
commitdd9009c96adb3bf280aa41a446ec950293b6f9a2 (patch)
tree0f8097cbd793ebdc9562183db4c37370d30314bd /x11-libs
parentStable on amd64 wrt bug #343143 (diff)
downloadgentoo-2-dd9009c96adb3bf280aa41a446ec950293b6f9a2.tar.gz
gentoo-2-dd9009c96adb3bf280aa41a446ec950293b6f9a2.tar.bz2
gentoo-2-dd9009c96adb3bf280aa41a446ec950293b6f9a2.zip
Add QTCONFIG definition for EGL too. Bug 340355. Thanks to Andrei Slavoiu <ansla80@yahoo.com> for the patch
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-opengl/ChangeLog9
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.7.0-r1.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index e55bb61f263e..77d93e5db534 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.77 2010/10/23 15:35:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.78 2010/10/29 11:17:45 hwoarang Exp $
+
+*qt-opengl-4.7.0-r1 (29 Oct 2010)
+
+ 29 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qt-opengl-4.7.0-r1.ebuild:
+ Add QTCONFIG definition for EGL too. Bug 340355. Thanks to Andrei Slavoiu
+ <ansla80@yahoo.com> for the patch
23 Oct 2010; Raúl Porcel <armin76@gentoo.org> qt-opengl-4.6.3.ebuild:
alpha/arm/ia64/sparc stable wrt #341703
diff --git a/x11-libs/qt-opengl/qt-opengl-4.7.0-r1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.7.0-r1.ebuild
new file mode 100644
index 000000000000..b26bee44b6c9
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.7.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.7.0-r1.ebuild,v 1.1 2010/10/29 11:17:45 hwoarang Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="egl qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,debug=,egl=,qt3support=]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/opengl
+ src/plugins/graphicssystems/opengl"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenGL
+ src/corelib
+ src/gui
+ src/opengl
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="opengl"
+ QCONFIG_DEFINE="QT_OPENGL $(use egl && echo QT_EGL)"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)
+ $(qt_use egl)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}