summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-14 23:00:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-14 23:00:38 +0000
commite67009b1cd95844b036f6b4f2d5b749a817f6d3f (patch)
tree4467901c4af62c92cf01dd0c7735d3a990c9d08f /x11-libs
parentfixing typo (diff)
downloadgentoo-2-e67009b1cd95844b036f6b4f2d5b749a817f6d3f.tar.gz
gentoo-2-e67009b1cd95844b036f6b4f2d5b749a817f6d3f.tar.bz2
gentoo-2-e67009b1cd95844b036f6b4f2d5b749a817f6d3f.zip
Fixing bug #172219, Thanks to Arfrever Frehtes Taifersar Arahesis
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-core/ChangeLog7
-rw-r--r--x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild13
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index e0e398246000..da3c238434b3 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.29 2009/02/14 15:09:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.30 2009/02/14 23:00:37 hwoarang Exp $
+
+ 14 Feb 2009; Markos Chandras <hwoarang@gentoo.org>
+ qt-core-4.5.0_rc1.ebuild:
+ Fixing bug #172219. Thanks to Arfrever Frehtes Taifersar Arahesis
+ <Arfrever.FTA@GMail.Com>
*qt-core-4.4.2-r2 (14 Feb 2009)
diff --git a/x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild b/x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild
index b0c2149af9a4..e30af6ebae71 100644
--- a/x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild,v 1.4 2009/02/14 00:04:03 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.5.0_rc1.ebuild,v 1.5 2009/02/14 23:00:38 hwoarang Exp $
EAPI="2"
inherit qt4-build
@@ -111,6 +111,17 @@ src_unpack() {
done
}
+src_prepare(){
+ # bug #172219
+ if use custom-cxxflags;then
+ sed -i -e "s:CXXFLAGS.*=:CXXFLAGS=${CXXFLAGS} :" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix CXXFLAGS failed"
+ fi
+ sed -i -e "s:LFLAGS.*=:LFLAGS=${LDFLAGS} :" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix LDFLAGS failed"
+ qt4-build_src_prepare
+}
+
src_configure() {
unset QMAKESPEC