summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-17 07:37:32 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-17 07:37:32 +0000
commitf3f4723187464a244f3b661271dc5dc80c298439 (patch)
tree9463e7c172c69380af0167e6abaebc222424d997 /x11-libs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-f3f4723187464a244f3b661271dc5dc80c298439.tar.gz
gentoo-2-f3f4723187464a244f3b661271dc5dc80c298439.tar.bz2
gentoo-2-f3f4723187464a244f3b661271dc5dc80c298439.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/ChangeLog8
-rw-r--r--x11-libs/pixman/pixman-0.18.4.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-libs/pixman/ChangeLog b/x11-libs/pixman/ChangeLog
index b68002331f31..ae0643e8eab2 100644
--- a/x11-libs/pixman/ChangeLog
+++ b/x11-libs/pixman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pixman
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.71 2010/07/22 16:22:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.72 2010/08/17 07:37:32 scarabeus Exp $
+
+*pixman-0.18.4 (17 Aug 2010)
+
+ 17 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +pixman-0.18.4.ebuild:
+ Version bump.
22 Jul 2010; Markus Meier <maekke@gentoo.org> pixman-0.18.2.ebuild:
arm stable, bug #327777
diff --git a/x11-libs/pixman/pixman-0.18.4.ebuild b/x11-libs/pixman/pixman-0.18.4.ebuild
new file mode 100644
index 000000000000..54d3976d3c26
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.18.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.18.4.ebuild,v 1.1 2010/08/17 07:37:32 scarabeus Exp $
+
+EAPI=3
+inherit xorg-2 toolchain-funcs versionator
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/pixman"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec mmx sse2"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ CONFIGURE_OPTIONS="
+ $(use_enable altivec vmx)
+ --disable-gtk"
+
+ local enable_mmx="$(use mmx && echo 1 || echo 0)"
+ local enable_sse2="$(use sse2 && echo 1 || echo 0)"
+
+ # this block fixes bug #260287
+ if use x86; then
+ if use sse2 && ! $(version_is_at_least "4.2" "$(gcc-version)"); then
+ ewarn "SSE2 instructions require GCC 4.2 or higher."
+ ewarn "pixman will be built *without* SSE2 support"
+ enable_sse2="0"
+ fi
+ fi
+
+ # this block fixes bug #236558
+ case "$enable_mmx,$enable_sse2" in
+ '1,1')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --enable-sse2" ;;
+ '1,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --disable-sse2" ;;
+ '0,1')
+ ewarn "You enabled SSE2 but have MMX disabled. This is an invalid."
+ ewarn "pixman will be built *without* MMX/SSE2 support."
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ '0,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ esac
+}