summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-30 06:50:04 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-30 06:50:04 +0000
commit5260bd3786a3e75bfff397a90aefdb836866e4cf (patch)
treea75837205a96c7318ee5e3672a5fc3956e3f260c /x11-misc/bbkeys
parentoopsie again (diff)
downloadgentoo-2-5260bd3786a3e75bfff397a90aefdb836866e4cf.tar.gz
gentoo-2-5260bd3786a3e75bfff397a90aefdb836866e4cf.tar.bz2
gentoo-2-5260bd3786a3e75bfff397a90aefdb836866e4cf.zip
Fixed rouge doc location. Added pkg_postinst sanity
Diffstat (limited to 'x11-misc/bbkeys')
-rw-r--r--x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild40
-rw-r--r--x11-misc/bbkeys/bbkeys-0.8.2-r1.ebuild27
-rw-r--r--x11-misc/bbkeys/bbkeys-0.8.2.ebuild28
-rw-r--r--x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r11
-rw-r--r--x11-misc/bbkeys/files/digest-bbkeys-0.8.2-r1 (renamed from x11-misc/bbkeys/files/digest-bbkeys-0.8.2)0
5 files changed, 27 insertions, 69 deletions
diff --git a/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild b/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild
deleted file mode 100644
index 039f7af139a5..000000000000
--- a/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Joe Bormolini <lordjoe@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.3.6-r1.ebuild,v 1.1 2001/08/29 15:17:38 lamer Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="bbkeys"
-SRC_URI="http://movingparts.thelinuxcommunity.org/bbkeys/${A}"
-HOMEPAGE="http://movingparts.thelinuxcommunity.org"
-
-DEPEND=">=x11-wm/blackbox-0.61 qt? ( >=x11-libs/qt-x11-2.3.0 )"
-
-src_compile() {
-
- if [ "`use qt`" ] ; then
- cd ${S}/bbkeysconf-1.3
- local qtdir=${QTDIR}
- try make MOC=${qtdir}/bin/moc CXXFLAGS="-I${qtdir}/include" LIBS="-L${qtdir}/lib -L/usr/X11R6/lib -lqt -lX11"
- fi
- cd ${S}
- try ./configure --prefix=/usr/X11R6 --host=${CHOST}
- try emake
-
-}
-
-src_install () {
-
- if [ "`use qt`" ] ; then
- cd ${S}/bbkeysconf-1.3
- into /usr/X11R6
- dobin bbkeysconf
- fi
- cd ${S}
- try make DESTDIR=${D} install
- cd /usr/X11R6/bin/wm
- cp blackbox blackbox.bak
- sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbkeys \&\n&": blackbox.bak > blackbox
-}
-
diff --git a/x11-misc/bbkeys/bbkeys-0.8.2-r1.ebuild b/x11-misc/bbkeys/bbkeys-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..bb6d391c1a74
--- /dev/null
+++ b/x11-misc/bbkeys/bbkeys-0.8.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.8.2-r1.ebuild,v 1.1 2001/08/30 06:50:04 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Use keyboard shortcuts in the blackbox wm"
+HOMEPAGE="http://movingparts.thelinuxcommunity.org"
+SRC_URI="http://movingparts.thelinuxcommunity.org/bbkeys/${P}.tar.gz"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_compile() {
+ ./configure --prefix=/usr/X11R6 --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ rm -rf ${D}/usr/X11R6/doc
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ cd ${ROOT}usr/X11R6/bin/wm
+ sed -e "s/.*blackbox/exec \/usr\/X11R6\/bin\/bbkeys \&\n&/" blackbox | cat > blackbox
+}
diff --git a/x11-misc/bbkeys/bbkeys-0.8.2.ebuild b/x11-misc/bbkeys/bbkeys-0.8.2.ebuild
deleted file mode 100644
index aa85661b30bb..000000000000
--- a/x11-misc/bbkeys/bbkeys-0.8.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Joe Bormolini <lordjoe@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.8.2.ebuild,v 1.1 2001/08/29 15:17:38 lamer Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Use keyboard shortcuts in the blackbox wm"
-SRC_URI="http://movingparts.thelinuxcommunity.org/bbkeys/${A}"
-HOMEPAGE="http://movingparts.thelinuxcommunity.org"
-
-DEPEND=">=x11-wm/blackbox-0.61"
-
-src_compile() {
-
- try ./configure --prefix=/usr/X11R6 --host=${CHOST}
- try emake
-
-}
-
-src_install () {
-
- try make DESTDIR=${D} install
- cd /usr/X11R6/bin/wm
- cp blackbox blackbox.bak
- sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbkeys \&\n&": blackbox.bak > blackbox
-}
-
diff --git a/x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r1 b/x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r1
deleted file mode 100644
index f3422a54e53e..000000000000
--- a/x11-misc/bbkeys/files/digest-bbkeys-0.3.6-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a8d24c463ea8900c4f5e5fdbc4ee8f9f bbkeys-0.3.6.tar.gz
diff --git a/x11-misc/bbkeys/files/digest-bbkeys-0.8.2 b/x11-misc/bbkeys/files/digest-bbkeys-0.8.2-r1
index 5016d7965c30..5016d7965c30 100644
--- a/x11-misc/bbkeys/files/digest-bbkeys-0.8.2
+++ b/x11-misc/bbkeys/files/digest-bbkeys-0.8.2-r1