summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-06-11 09:12:38 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-06-11 09:12:38 +0000
commitdb1267a7b3a8373383e14764f5c25dc107e67017 (patch)
treea043b5f3ad9d81a6747469a3d31775d9dd171286 /x11-misc/bbrun
parentFix underlinking wrt #370127, bump to EAPI4, don't install useless docs (diff)
downloadgentoo-2-db1267a7b3a8373383e14764f5c25dc107e67017.tar.gz
gentoo-2-db1267a7b3a8373383e14764f5c25dc107e67017.tar.bz2
gentoo-2-db1267a7b3a8373383e14764f5c25dc107e67017.zip
Fix underlinking wrt #367853. Remove multilib eclass, bump to EAPI4, simplify ebuild
(Portage version: 2.2.0_alpha36/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/bbrun')
-rw-r--r--x11-misc/bbrun/ChangeLog9
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild34
-rw-r--r--x11-misc/bbrun/files/bbrun-1.6-makefile.patch29
3 files changed, 71 insertions, 1 deletions
diff --git a/x11-misc/bbrun/ChangeLog b/x11-misc/bbrun/ChangeLog
index c7b9c45dcd83..166df9b8283a 100644
--- a/x11-misc/bbrun/ChangeLog
+++ b/x11-misc/bbrun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/bbrun
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/ChangeLog,v 1.24 2011/04/10 07:55:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/ChangeLog,v 1.25 2011/06/11 09:12:38 xarthisius Exp $
+
+*bbrun-1.6-r1 (11 Jun 2011)
+
+ 11 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org> +bbrun-1.6-r1.ebuild,
+ +files/bbrun-1.6-makefile.patch:
+ Fix underlinking wrt #367853. Remove multilib eclass, bump to EAPI4, simplify
+ ebuild
10 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> metadata.xml:
Change herd from nonexisting commonbox to desktop-wm
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
new file mode 100644
index 000000000000..5c2191ba126e
--- /dev/null
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.6-r1.ebuild,v 1.1 2011/06/11 09:12:38 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="blackbox program execution dialog box"
+HOMEPAGE="http://www.darkops.net/bbrun"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ x11-libs/libXpm
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake -C ${PN} CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin ${PN}/${PN}
+ dodoc Changelog README
+}
diff --git a/x11-misc/bbrun/files/bbrun-1.6-makefile.patch b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
new file mode 100644
index 000000000000..cf89b96df6f3
--- /dev/null
+++ b/x11-misc/bbrun/files/bbrun-1.6-makefile.patch
@@ -0,0 +1,29 @@
+Respect {C,LD}FLAGS, fix underlinking
+
+http://bugs.gentoo.org/367853
+
+--- bbrun/Makefile
++++ bbrun/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ LIBDIR = -L/usr/lib -L/usr/X11R6/lib
+-LIBS = -lXpm `pkg-config --libs gtk+-2.0`
+-CFLAGS = `pkg-config --cflags gtk+-2.0`
++LIBS = `pkg-config --libs xext xpm gtk+-2.0`
++DEP_CFLAGS = `pkg-config --cflags xext xpm gtk+-2.0`
+
+ OBJS = bbrun.o \
+ ../wmgeneral/wmgeneral.o \
+@@ -11,10 +11,10 @@
+ all: bbrun
+
+ .c.o:
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) $(DEP_CFLAGS) -c -Wall $< -o $*.o
+
+ bbrun: $(OBJS)
+- $(CC) -Wall -g -o bbrun $^ $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -o bbrun $^ $(LIBDIR) $(LIBS)
+
+ install:
+ cp bbrun /usr/local/bin/